Add Boot Option using Insydeh20 setup utility


I have a Dell Inspiron 7520 (i7 processor) laptop. When I tried to start my system it showed the spinning icon, and after few seconds, it showed me a blue screen with the following error message:

"Your PC ran into a problem and needs to restart. We're just collecting some error info, and then we'll restart for you".

Once it shows the above message, the system restarts and then repeats the same process of showing the same error message and restarting. This keeps happening in a loop.

The software running in the BIOS is Insydeh20 setup utility.

I managed to get a copy of Windows 8 on a USB drive. In order to boot from the USB, I got into the Bios (using F2) and tried to "Add boot option," as there were no other boot options present. When I tried to do that, it asked me to provide a name. I entered "USB". It then added it & allowed me to edit properties of this option. When I tried to edit the property, it asked for File system path. Because this is a USB drive, I do not have a clue as to what this value should be & how to set this USB drive as the first priority.

Any instructions on how to set the file system path for the USB drive and how to set it as the first priority will be greatly appreciated.

Thank you.

Answered! View the answer I have this problem too

Is this a good question?

Score 5


Did you make your USB drive bootable when you copied Win8?

by oldturkey03

I have 7520 and I can't boot from USB pen drive.

Dear oldturkey03! The problem isn't the booting capable of pen drive. The real problem is a BIOS of 7520, because we can't set the boot device to USB.

by sandorh

Thank you for this.

by Jake West

Add a comment

8 Answers

Chosen Solution

I had this issue—most irritating. I have a 7520 i7, with insydeH20 A9 BIOS. The issue is UEFI. You need to enable legacy boot.

  • Start the machine and hit F2 to get to BIOS.
  • Disable secure boot in the boot options screen.
  • Enable the load legacy option ROM.
  • Keep the boot list option set to UEFI.
  • Press F10 to save and exit.
  • Shut down the machine and start it again with the USB device attached.
  • Press F12 on boot to get the legacy boot options.
  • Pick USB from the list, and off you go.

Was this answer helpful?

Score 30


Thank you Graham White, your answer works perfectly!

by Hans Hansen

Brilliant, worked perfectly, thank you.

by Bob

i have a hp 245 bassed on linux suse, your configuration works! thank you so much

by Ciber Duran

Thanks, workt perfektly on Lenovo G710 withinsydeH20 rev 3.7

by GorAran

Same problem but, when the USB device is added, I cant scroll down to choose it! What am I doing wrong?!

by revolva

Show 8 more comments

Add a comment

Try adding the files to a bootable CD and try booting from the CD, this is what i would do in my own opinion.

Was this answer helpful?

Score 1
Add a comment

You need to create a UEFI specific boot USB drive to boot usb devices with a UEFI system. Some Dell models (like my new Inspiron 11) doesn't even have a legacy mode.

1) Disable UEFI secure boot (this is a key exchange that occurs for an installed system)

2) Create a UEFI enabled Windows OR Linux usb drive (MUST be formatted FAT16 or FAT32):


Windows 8:

3) When you boot, press F12. If done correctly, it SHOULD show up as a bootable device.

Just went through this crap tonight and randomly answering forums in hopes of saving other people from this headache!


Was this answer helpful?

Score 0
Add a comment

THe same issue is with Sony Viao, with Vista x64 installed..However the Insydeh20 bios on these Viaos dont show an option to disable Secure Boot..what should be done then, infct every other option on a VIAO is in pain.

Was this answer helpful?

Score 0
Add a comment

Same issue with my lenovo g570 with windows 8. The insydeh20 of m g570 dont show an option to disable secure boot ang the UEFI option. I want to downgrade it from windows 8 to windows 7 but how can i do that if these two option is inaccessible? Please help me. Thank you in advanceadvance

Was this answer helpful?

Score 0
Add a comment

I have an Acer Aspire V3-551 and i have no idea what to do in insydeh20 setup utillity. I've spend so Many Hours trying to figure it out but i have no idea how to reboot my computer. Im stuck in insydeh20 i cant do anything besides that program. And i dont have Any "load legacy option ROM" im totally blank for options to reboot my computer. And honestly i dont know what ANYTHING means in insydeh20. Like all the "bios, Uefa". I just hate my lige Right now.

Please help me!

Was this answer helpful?

Score 0
Add a comment

Hi, I not have this problem but after disabling Legacy boot my pc restarts and turns to black nothing shows up I think I didn't enabled uefi boot also. Please help

Was this answer helpful?

Score 0
Add a comment

how i increase my dedicated video memory?????? HELP plzzzzzzzzzzzz>>>>>....

Was this answer helpful?

Score 0
Add a comment

Add your answer

David will be eternally grateful.