MacBook Pro 13" Unibody Mid 2009

Mid 2009 Model A1278 / 2.26 or 2.53 GHz Core 2 Duo processor EMC 2326

561 Questions View all

Hard drive changed but not seen on the disk utility

Hi,

I bought a new hard drive for my macbook pro 13" unibody 2009, i bought a Western Digital Scorpio Black 750Go, to change my poor old 160Go.

I've installed it correctly on the macbook pro, and when i put an install cd, it's not seen by the utility disk.

The only thing it sees is the optical drive, not the hard drive.

When i put the WD Drive on an another mac (or pc) as an external drive, it works.

Does this disk not compatible with my mac? or is it something else?

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

See if this firmware update fixes your problem EFI 1.7 Update If your system is already running this or you don't see any improvement you'll need to use a jumper on your HD to set it for the older SATA data rate. Review WD documentation that came with your drive on locating the jumper setting.

Was this answer helpful?

Score 1

Comments:

There are jumper pins located on the same side of the hard drive as where the cable plugs into it. There is a diagram on top of the HD showing how they should be jumped for each setting. The hard drive needs set to 1.5GBs to properly communicate with the HD controller.

by ABCellars

Add a comment

Add your answer

Baptiste BUREAU will be eternally grateful.

View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 484