Why won't my new HDD mount?

1) Installed new HDD per ifixit DIY guide.

2) Went to install OSX (Snow Leopard) but the drive didn't mount so Disk Utility couldn't see it to format.

3) Rechecked connections and it still didn't show up.

4) Reinstalled old HDD and it mounts (disk is corrupt though)

5) For fun, we installed the new HDD in the external enclosure and it successfully mounted via USB. We formatted it (Mac OS Extended -- Journaled), took it out of the enclosure and reinstalled in the MBP, and the machine still doesn't see the drive.

Resetting the PRAM and SMC were attempted, but unsuccessful.

My brain is sad.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

When you had it in the external case did you reformat the drive? Sounds like you have a FAT formatted drive which is why your Mac won't boot but when in an external case can be seen.

Was this answer helpful?

Score 3


Yepp. As I mentioned in step 5 we formatted the drive (Mac OS Extended -- Journaled) via USB and reinstalled it, but it still wouldn't mount for Disk Utility.

After researching this problem a bit more I'm thinking it might be the HDD cable. We tried the tape fix ala Jose Ochoa (Internal hard drive disk not recognized), but it didn't seem to help.


OK, Just double checking. Check the specs of your new drive you may need to set a jumper to alter the SATA speed (lower) as the older systems don't support the higher speed.


correct on the jumper settings change!


No jumper on the old drive and no jumper came with the new HDD.


Did you check the vendors web site for jumper settings for this drive? You may need to find a jumper some where (one that fits - many different sizes!) Can you supply us the HD info? If you still can't figure out what to set.


Show 6 more comments

Add a comment

Add your answer

tlhaas will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 1,665