Sit-on-top lawn mower. Zero-turn radius mower, 50" mower deck, hydro transmission.

44 Questions View all

mower deck will not engage when the PTO switch is turned on?

When the PTO switch is turned on the mower deck does not come on. I have replaced the PTO switch but it still does nothing. Could the electric clutch be bad?

Answered! View the answer I have this problem too

Is this a good question?

Score 12

Comments:

Mower will engage but will not drive foward or reverse even without mover engaged

by

I have the same problem. When I engage PTO switch mower blades wont turn. I hard wired from battery to electric clutch and mower blades came on, so that I know its not my clutch or adjustment. Replaced switch and it still didn't work. Please help.

by

Add a comment

6 Answers

Chosen Solution

Chris, first try to adjust the clutch. I attached some images from the manual. check the wiring. If the wiring does not reveal any problem and a clutch adjustment does not resolve it, it may be time to replace the clutch. Also check mower deck will not lower Hope this helps, good luck.

Block Image

Block Image

Block Image

Was this answer helpful?

Score 3

Comments:

I replaced the clutch and it's working great. Thanks

by

You are welcome :-)

by

this is not an electric clutch, but a manual one

by

@ken67 what clutch?

by

I have same problem but when I turn pto it try's to engage I can hear and see somethings working upper side of clutch but nothing to the belt pully

by

Show 7 more comments

Add a comment

I see you have fixed your problem but FYI to anyone reading this, I had the same issue with the mower not engaging and found the normally open contact on the mower deck engage button was bad. it was around $30 bucks to replace the button. I Needed a continuity checker to test and find this issue.

Was this answer helpful?

Score 1

Comments:

where was that button

by

What keeps the top half of the clutch from spinning with the bottom pulley

by

Snapper Z1401K new clutch new switch clutch kicks on when starting still does not engage?

by

Add a comment

I had the same problem... I found one of the wires had rubbed of the plastic coating near the clutch and was grounding out. I put a shrink wrap tube on it and rerouted the wire from where it was rubbing. Haven't had a problem since.

Was this answer helpful?

Score 0

Comments:

What reasons are there for my pto clutch starting up and running fine for about 5 minutes then the blades just stop .

I put a new pto clutch on and still same problem .

Any help would be appreciated.

by

Add a comment

g'day every one,this may sound a bit unsafe but before you go and get a new PTO switch,or a new clutch, hot wire the clutch, run it to a on/off switch(you have to put the switch on your self)leave your PTO switch off(down not up) start the mower turn the new switch(hot wire) on and leave PTO switch off,if deck works you can mow even in reverse but rember the switch keeps the deck going all the time till you switch it off .then you can have a lecky check your wiring as it won't be your clutch,but you can get your lawn cut.

Was this answer helpful?

Score 0

Comments:

My ingage button blows a fuse wen i try to ingage the the blades.

by

Add a comment

Husqvarna RX5424 Last year we had some issues with it not wanting to start, but it was the seat switch out of place, and

Kept blowing the fuse under the seat. Its fine now and starts and runs fine.

However, the PTO will not engage. I’ve traced the wires to the pto clutch and switch,

and everything looks fine.

Can you give me some ideas of things to look at?

Is there a fuse or circuit breaker?

It will not start with the PTO engaged (good), but that tells me that there is a good connection somewhere.

I unplugged the switch and plugged it back in.

I unplugged the harness by the engine and cleaned it, it looks good.

Doesn’t look like any other broken wires.

Could it be that seat switch acting up again only not letting PTO start?

I think I will try to hard wire the PTO clutch harness and see if it engages then? Then it has to be a safety switch or PTO switch?

Was this answer helpful?

Score 0

Comments:

Battery= Perfect. Ordered switch. The old one worked and then quit again. I got new switch, but before I installed it, I hot wired it, it worked again, w the old switch, it worked.

Wouldn’t work with new switch.

SO, I traced wires to the back again, and the stupid, bad, poor design connector in the back wasn’t making good connection. Cleaned them all, taped them all up, works perfect. The short little adapter pigtail harness from the machine to the PTO connector, and it was shorting out. Installed old switch and all was well. Greased the machine and blades with a synthetic grease, sharpened blades, complete & master tune up and oil change, pressure washed, mowed for 2 hours with it, and it was fine.

I will wire the adapter directly to the harness w solder shrink tube butt connectors, should have been in the first place.

Ordered another set of Gator blades, a Stens oil change kit. Seat and brake switch quit also!

This was also blowing fuse under the seat - installed circuit breaker/fuse

by

Add a comment

My charging system was not working correctly. The battery was too weak to engage the blades. Tired of charging the battery often and no time to work on the mower, I purchased a 1.5W solar trickle charger from Harbor Freight for $14 that I leave connected.

My battery now keeps a full charge and have not had any starting or blade problems for 6 months.

https://www.harborfreight.com/15-watt-so...

Was this answer helpful?

Score 0

Comments:

I had mine on the charger for several days before I serviced it. I like to fully charge it after putting it back into the mower. I take it out in the winter and put it on a maintain setting for the winter. It had 13.8 volts when I moved it into the shop from the storage shed, and was running 14.0 approx when running at an idle. Does anyone know what the voltage at the harness should be? (the disconnect beside the engine going to the clutch?) I have hard a weak battery before, and agree, the clutch didnt engage then.

by

Add a comment

Add your answer

Chris will be eternally grateful.
View Statistics:

Past 24 Hours: 694

Past 7 Days: 4,356

Past 30 Days: 18,717

All Time: 124,222