Complete disassembly and installation guides for most recent Mac laptops and consumer desktops.

28841 Questions View all

MacBook Pro won't load past white apple logo screen

The macbook pro won't load past the apple logo screen, I tried command+s on start up, and I tried command + v on startup, It showed me a repeated error message

jnl:unkown-dev:do_jnl_io:strategy ewrr 0x5

jnl: unknown dev: could not read 512 bytes for the journal header.

hsf: late jnl init: failed to open/create journal (retrieval 0)

hsf_mounthfsplus: hsf_late_journal_init returned (22)

hsf_mounthfplus: encountered error (22)

hsf_mountfd: encountered failure 22

hsf_mountroot: hsf_mountfs returned 22 rvp (0xffffff800badff00) name (Unknown device)

cannot mount root, errno = 19

rooting via boot-uuid from /chosen: 3CF4A65E-EE84-3174-B212-9014999EF1AF

waiting on <dict ID="0"><key>IOProviderClass</key><string ID="1">IOResources</string><key>IOResourcematch</key><keystring ID="2">boot-uuid-media</string></dict>

Got boot on device = IOService:/AppleACPIPlatformExpert/PCI0@0/AppleAPIPCI/SATA@1F ,2/AppleIntelPchSeriesAHCI/PRT0@0/IOAHCIDevice@0/AppleAHCIDiskDriver/IOAHCIBlock

StorageDevice/IOBlockStorageDriver/TOSHIBA MK5065GSXF Media/IOGUIDPartit

BSD root: disk0s2

disk0s2: I/O error

0 [Level 3] [ReadUID 0] [Facility com.apple.system.fs] [Err type IO] [ErrNo 5] [IOType Read] [PBlkNum 515184] [FSLogMsgID 2064894641] [FSLogMsgOrder First]

0 [Level 3] [ReadUID 0] [Facility com.apple.system.fs] [FSLogMsgID 1051684345] [FSLogMsgOrder Last]

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment
Deck the Halls
With tools and Fix Kits

1 Answer

Chosen Solution

Try a safe (shift) boot. Try booting to your install disk or AHT (D boot).

If this answer was helpful please remember to return and mark it Accepted.

Was this answer helpful?

Score 0
Add a comment

Add your answer

karen smith will be eternally grateful.
View Statistics:

Past 24 Hours: 3

Past 7 Days: 12

Past 30 Days: 36

All Time: 2,987