Netgear router won't turn on ¶ 

My router has no power.

No Power Connection ¶ 

The router might not be turning on if it is not correctly connected to a power source. Make sure that the round end of the power cord is properly plugged in the last slot on the left in the back of the device and the prong end into the power source (i.e. wall or power strip).

Restart ¶ 

If you find that the device is properly plugged in but the router still won't turn on, try to restart it. Unplug end of cable connected to the electrical outlet, wait for 30 seconds and then plug the device back in.

Router has a weak signal ¶ 

My computer cannot connect to the internet.

Incorrectly Inserted Input/Output Cables ¶ 

The router might be giving off a weak signal if the input and output cables are incorrectly inserted. The ethernet cable, from the modem, should be plugged into the yellow input slot located in the back of the device. Any outgoing cables (ie. to computer, printer, game station) should be plugged into the black output slots. Make sure that they are pushed all the way in for optimal connection.

Invalid IP Address ¶ 

One reason that you are unable to connect to the internet is that your computer (or other devices) may not be receiving the correct IP address from the router. Verify that the IP address that is being sent from the router is the correct one.

Interference ¶ 

Weak connection can be caused by interference from other devices. Try to keep the router away from microwaves, cordless phones or anything wireless. A lot of these devices operate at the same frequency and keeping them farther apart will reduce unwanted interference.

Out of Date Firmware ¶ 

Updating the routers firmware can rid the device of any software glitches that it may have. The fixing of a certain glitch could improve the connection power. Click here download the latest version of firmware.

Reset ¶ 

If none of the above solutions fix the connection problem, you should reset the router to its original manufacturing settings. This should fix any functioning problems that the device may be having. Just note, you will need to redo the setup for the username and password.

Defective Antenna ¶ 

The antenna attached to the router could be damaged or faulty causing the wireless connection to malfunction. Replacing it could improve the wireless hotspot range.

Unnatural Sounds ¶ 

My router is making annoying noises.

Buzzing Noise ¶ 

If you are hearing buzzing sounds coming from the router, it can due to a faulty capacitor. Replacing it can save you from that annoying sounds and can increase the life of the device.

None of the above ¶ 

Nothing above matches your problem, or you've tried a solution suggested above, but it didn't help.

If none of the above problems match the problem that you are having, you can ask questions on the Netgear WGR614v9 Question Page and someone will be able to answer any question you may have. You can also get the user manual and other resourceful documents at the Netgear website and clicking on resources.

One Comment

All of my plugs are in correctly but the power still won't turn on?

Trenton Mays - Reply

View Statistics:

Past 24 Hours: 12

Past 7 Days: 53

Past 30 Days: 285

All Time: 19,696