Student-Contributed Wiki

Student-Contributed Wiki

An awesome student from our education program made this wiki. It is not managed by iFixit staff.

Camera will not turn on ¶ 

The device will not turn on when the power button is pressed ¶ 

Dead battery ¶ 

This may be due to the fact that the battery is dead. You will need to take the battery out of the bottom of the camera and charge it. Once the battery is charged, put it back in the camera and turn it on.

Needs to Reboot ¶ 

Remove the memory card from the camera. Leave it for 10-15 minutes and then re-insert it and power the device on. You may need to input date and time again.

Needs to Connect to Computer ¶ 

Connect the camera to your computer using the USB cable. After it is connected for a couple of minutes, try turning on the camera.

Flash on camera will not pop up ¶ 

When you try to take a picture the flash will not open

Flash Button Needs to be Pressed ¶ 

Push the flash button (has an icon next to it that looks like a lightning bolt) on the front of the camera next to the lens to activate the flash.

Obstruction to the Flash ¶ 

Make sure that there is nothing obstructing the flash. If nothing is in the way, gently pull on it to try and get it to pop up.

Wrong camera settings ¶ 

Change the camera setting to full auto (green frame), portrait (face), or macro mode (flower) to activate the flash to pop up.

Error 99 message ¶ 

When trying to take pictures the message "Error 99 shooting not possible" pops up.

Camera needs to Reboot ¶ 

Turn the camera off, take out the battery, and then turn the device back on again. If that does not work, it may be required to sit with the camera off and battery out for approximately 20 minutes.

Problem with the Lens ¶ 

Try cleaning the lens with a soft cloth. If this does not help, then try using a different lens on the camera.

Problem with the Memory Card ¶ 

Try using a different memory card or reformatting your old one (this will erase all of your pictures so be sure to save them on a computer first.)

Autofocus not working ¶ 

The camera will not autofocus.

Dirty Lens ¶ 

The first thing to try if autofocus is not working is to simply clean the lens with a soft cloth.

Wrong Mode Setting ¶ 

If the camera is set to "MF" then it will not autofocus. Be sure to set the camera mode to "AF."

Wrong Setting ¶ 

Go to settings in [C.Fn-9] and make sure it is set to option 0 (AF/AE lock).

Problem with the Flex Cable ¶ 

Follow this link to replace the flex cable. Flex Cable Replacement

No Response From Shutter Button ¶ 

The shutter button has no effect and won't take a picture

Camera needs to Reboot ¶ 

Take the battery out for about 30 seconds and then put it back in.

Problem with the lens ¶ 

Try swapping lenses to make sure that it's a problem with the camera.

Problem with autofocus ¶ 

Make sure that there is enough light for the camera to focus. If that doesn't work, try switching to manual focus or "Al Servo" mode in case it's a problem with autofocus.

2 Comments

Camera always shows error #99

Byron Hill - Reply

My Canon Eos Xsi always shows "error" 99 when I try to use it - even with the lens detached

Byron Hill - Reply

View Statistics:

Past 24 Hours: 3

Past 7 Days: 5

Past 30 Days: 21

All Time: 1,071