Cambridge Audio A3i Amplifier Troubleshooting

A3i Amplifier ¶ 

The Cambridge Audio amplifier was originally manufactured in 1996. Included on this page are instructions one should follow when they come across some common problems

Amplifier won't turn on ¶ 

This problem can be addressed easily by examining the power cord for any possible tears or breaks. If none exist, then you must follow the steps outlined in the repair guide to remove the top cover and back panel of the device. Now the power cord can be examined and assessed for any breaks, tears, or disconnections to the internal power source.

LED light burned out ¶ 

In the case that one or more of the LED lights do not turn on, a few, simple steps must be taken. Similar to above, the steps to remove the top cover of the device must be completed in order to obtain a proper view of the LED's. If replacing any burned out bulbs fails, you may want to obtain a soldering kit to replace the light and connections holding it to the motherboard.

Loud static noise is heard ¶ 

If the sound heard through the speakers is not clear, that is, if static noise comes through, one of the LED's inside may be faulty. You must follow the repair guide that prompts you to open the amplifier case and view the motherboard. Then with a soldering kit, you must replace the green LED light marked LED2. Once this is complete, the static noise should discontinue.

0 Comments

Add Comment

View Statistics:

Past 24 Hours: 0

Past 7 Days: 3

Past 30 Days: 13

All Time: 3,794