Dual Hard Drive #80

Prerequisite Only

Prerequisite Only

Please note that this guide is only a prerequisite for other guides.

Universal Pre-req for Optical Bay Enclosures #80 only

Universal Pre-req for Optical Bay Enclosures #80 only

Edit Step 1 Dual Hard Drive  ¶ 

Image #1

Edit Step 1 Dual Hard Drive  ¶ 

  • Remove the plastic spacer from the optical bay hard drive enclosure by pressing in on one of the clips on either side and lifting it up and out of the enclosure.

Edit Step 2  ¶ 

Image #1

Edit Step 2  ¶ 

  • Make sure that the hard drive connectors are facing down before placing it into the enclosure.

  • Gently place the hard drive into the enclosure's hard drive slot.

  • While firmly holding the enclosure in place with one hand, use your other hand to press the hard drive into the enclosure connectors.

Edit Step 3  ¶ 

Image #1

Edit Step 3  ¶ 

  • Once the hard drive is snug, reinsert the plastic spacer while holding the hard drive against the bottom of the enclosure.

Edit Step 4  ¶ 

Image #1

Edit Step 4  ¶ 

  • Use two Phillips #1 screws to secure the drive to its enclosure.

Edit Step 5  ¶ 

Image #1

Edit Step 5  ¶ 

  • Attach the optical drive bracket to the new enclosure with two Phillips #0 screws.

  • Reconnect any cables you have removed from the original optical drive onto the optical bay enclosure.

Edit Step 6  ¶ 

Image #1

Edit Step 6  ¶ 

  • Don't ditch that drive! You can still use your optical drive externally with the help of our SATA Optical Drive USB Cable.

  • Align the cable's SATA connector with the drive's port and plug in securely.

  • Plug the USB connector into your laptop and your optical drive is ready for use.

To reassemble your device, follow these instructions in reverse order.

For more information, check out the Optical Bay Enclosure device page.

Popular Products

iPhone 3GS Replacement Battery

$14.95 · 43 In stock

Phillips #00 Screwdriver

$8.95 · 50+ In stock

T5 Torx Screwdriver

$9.95 · 32 In stock

iSesamo Opening Tool

$9.95 · 50+ In stock

Comments Comments are onturn off

The bay and dvd drive cable at iFixit is $40.00 (http://www.ifixit.com/Apple-Parts/9-5-mm...)

But for $10 more you can get an external casing that will protect your super drive form MCE (http://store.mcetech.com/Merchant2/merch...) A total of $50 dollars. It is what I used and works great and looks pretty and is guaranteed to protect your superdrive. MCE also gives you a disk with software to patch the DVD Player to work with external dvd drives. So For an extra $10 dollars you get better software functionality and a case for your super drive. It works great.

Robert Wacker, · Reply

It is not a good idea to put fast SSDs into the optibay. System tries to negotiate at 6 Gbit, but it fails; disk is recognized but it couldn't even be formatted. I've waisted a lot of time to find a reason. After swapping SSD with original mac's HD both work properly, one at 6, another at 3 Gbit

nicholas, · Reply

No problems here with a Samsung EVO in the optical bay. Only downside that is not really fast (80-90 mb/s) but amazing performances on booting time, shut off and opening programs.

Mike, · Reply

I have to withdraw my comment. It is NOT a good idea to put a SATAIII SSD in the optical bay. It gives random freezes. Swapping it with a HD is indeed better. Better read/writes too. Only downside is that SMS won't work on the optical bay so treat your baby with care. Also Sleep issues might occur when placing a HD in the optical bay (a total freezing system). I already wasted a HD that was in the optical bay.

Mike, · Reply

I've replaced the optibay with a samsung 840 pro but can't format it nor copy files (a few files work) to it. Do you suggest putting the HDD in the optibay instead? Did you clone the HDD to the SSD before swapping them? Will my Mac boot from the HDD the first time I boot even though it's in the optibay? I would really appreciate an answer, I've spent too many hours trying to figure it out!

Carl, · Reply

Also had this same problem. Tried and failed a Samsung firmware upgrade. Ended up send drive back to Amazon.

Andrew,

Okay it seems like some models of MacBook Pro have issues with a fast (6Gbit/s) SSD in the optical bay. Even though my Mac says it offers 6Gbit on both bays it simply didn't work in the optical bay. So I switched places between the two drives and everything seems to work. My Mac booted from the old HDD in optical bay automatically and then I cloned it afterwards and changed the startup disk to the new one. As said before, don't put a fast SSD in the optical bay!

Carl, · Reply

My understanding is that SSDs will work (at 6Gbps) in the optical bay of late-2011 13" MBP models but not in late-2011 15" or 17" models and not in earlier 13" models. Are those of you reporting problems installing on late-2011 13" models (MD313LL/A [2.4Ghz] or MD314LL/A [2.8 GHz])?

Steve, · Reply

I'm experiencing the same issues with the HDDs in the optical bay. I've tried multiple drives (WD caviar blue 3G and a Seagate 6G) with no luck thus far. I replaced the SATA cable and that didn't help with either drive. My SSD still works fine in the main bay but I would like the extra storage.

For those of you who got the HDD in the optical bay working, which HDD (brand and model) did you use?

My MBP is a Late 2011 15" (8.2)

woestmab, · Reply

My understanding is that SSD in the optibay for 2011 MBPs will only work on the late-2011 13" model (not the 15" or 17"). I can confirm that it works in my late-2011 13" MBP. I have a Samsung EVO 500GB in my optibay (HGST 1TB in the hard drive bay) with no problems at all: negotiated link speed of 6Gbits for both drives and not beach balls or other slowdowns.

Steve,

I'm not trying to put an SSD in the optical bay. As I said, I've tried multiple HDDs but none of them seem to work. I know that it's possible to put an HDD in the optical bay because I bought the computer with one in it but it seems that none are recognized. I have tried multiple brands and speeds with no luck. I would like to know which specific model of HDD works in the late 2011 15" optical bay.

Thanks

woestmab,

Many people have this problem and they all had the 2011 MBP model. The SATA controllers are both 6Gb/s on optic drive and HDD from 2012 (mid 2012 anyway). And of course we're talking about the non-retina. The last non-retina came out mid 2012.

maniajami, · Reply

Make sure you have removed the 2 screws at the end of your super driver unit and move it to your NewHD bay with the metal piece eye loop.

Kamiiyu, · Reply

Normally with the HD enclosure there come a set of screws. use these to screw down the HD in the enclosure since you need to flip it up side down to reinstall it into the MBP

Bart, · Reply

Here they picture Crucial as their choice, you can also find some great options at Samsung (it is what I installed and it works just as good if not better than the crucial I installed in my wife's iMac. here is their site http://www.samsung.com/us/computer/solid...

Its just another great option. Also when installing SSDs make sure to enable TRIM support (crashes can and probably will occur if you don't) TRIM enabler is available free and the pro version is $10 http://www.cindori.org/software/trimenab... It is the easiest solution for this issue.

Robert Wacker, · Reply

With the particular drive bay adaptor I used, these attachment screws were already fitted to the adaptor but were found at the sides, not underneath. Indeed, the adaptor had no screw holes on the underside.

jjsanderson, · Reply

At first I couldn't get my machine to even turn on - thought it was the battery connector, but in the end I just had to reset the SMC. (http://support.apple.com/kb/ht3964 - see "Resetting the SMC on portables with a battery you should not remove on your own").

talksrealfast, · Reply

I have the drive installed with this bay, but the drive does not appear in the Disk Utility. I see a 'Nvidia MCP79 AHCI' in the system information, but no drive listed with it. Is there some special driver needed to get the MCP to see the drive?

toddfletcher, · Reply

Replaced the optical with hdd, as well as replaced the hard drive with an ssd. Now I get the circle with a line through it. But, when I hold the option key down, it gives me both hard drives, PLUS, the thumb drive I have in the USB port with a Mountain Lion installer. It even shows the recovery disks, but gives me the circle with the line when I choose one. Any help is appreciated.

claude, · Reply

Mate,

My mbp shipped with OS 10.8, and I had upgraded twice to 10.10

I've a 10.7 USB which upgraded my old MBP.

My plan today was to boot with my new ssd, my time machine back up and the Lion usb plugged in.

I would then click on the Lion usb, and tell it to put the OS and time machine back up on the ssd.

So I help down ALT and when it started it gave me the options of the usual Mac internal or the Lion USB.

I clicked Lion, but instead of taking me to the install options (Disk utility, restore from time machine etc etc) it gave me that grey circle with a diagonal line through it. The no entry sign - grey on grey - that I think you have.

Some googling said that it is because I was trying to usb a 10.7 install on a MBP that shipped 10.8

You can't go back, apparently.

So if any of the OSs are older than the mac you got, you will get this error. The grey in grey no entry.

I just cloned my HDD to my ssd (Carbon copy cloner free 30 day trial) using an external stat-usb3 wire and all is good.

Rory,

it does not recognize the hard drive in the enclosure, what should i do?

elvin00, · Reply

simple question, how do I use the removed drive to play a DVD? Why don't I just use digital media...yadayada...I know. I'm currently in the hospital, did this drive swap for busy work. The littles want to watch an old DVD and I can't solve the issue.

gator6, · Reply

This will give you instructions on how to get your DVD player to work in an external enclosure: http://macenstein.com/default/2011/07/ho...

Steve,

I have a 17" Macbook Pro6,1 unibody with an Intel Core i5, 2.53GHz. I was successful installing a 250GB SSD in the DVD bay, and I'm able to boot from it. I did this by first installing OS X 10.9.4 on the SSD mounted into an external HD case, testing the system to see if it would boot up into the SSD, then installing the SSD and carrier in the DVD drive bay. The system now boots up from the SSD with no problems. If you are having installation problems, I recommend trying this method.

roger hall, · Reply

This is really for step 23: reassembly

You can not get the orginal screws back in to hold the new optical drive replacement in place because there is a black plastic filler running along the front edge of the part. There is no place for the screw head to go. I had to remove some of the plastic to get the machine reassembled. Whoever tested this overlooked what I think is a major problem. How many macbook pros are out there with only one (maybe two if you're lucky) screw holding this thing in place?

I got extra screws and have no idea why. The bits included in the kit are poor and don't work on most of the screws. I had to use my own tools instead.

eetech, · Reply

Hi,

I'm using a 13' MBP mid 2010 and I just swapped my HDD for a SSD. Al works perfectly fine!

So i bought the unibody laptop dual drive (from iFixit) and replaced the optical drive for the original HDD from my MBP. The installation with this guide went perfectly, however, the HDD is not recognized in disk utility.

I put the old HDD back on the original HDD bay, the HDD boots and works. I placed back the optical drive in the optical bay, also works. But when i put the HDD in the unibody laptop dual drive (iFixit), it is not recognized via the USB-port(however, the HDD starts spinning) or when installed in the optical bay.

So i think there is a software issue where my MBP does not recognize a HDD in the optical bay. Is there a way to force the OS to look for storage/HDD via the optical bay STATA cable?

All help is welcome!

Thanks,

Leon

Leon, · Reply

Leon: did you fix your issue? I'm facing the same problem.

Rafael Borges,

No, afraid not..

Leon,

also having the same problem, not recognizing second hdd

cmaizan,

Hi!

I followed the tutorial and everything works fine when I use an HDD 320 go but when I use the new HDD I bought which is an Hitachi 1T 7200T 2.5 P I have some trouble. The disk utily takes a long time to recognize the new hard drive and then starts not responding.

I tought my new HDD might be broken but when I use it with an external portable HDD Enclosure it works fine...

Any ideas?

Thanks!

Julie

Julie Odeursa, · Reply

View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 84