Skip to main content

What you need

  1. Dell XPS 15 9575 Solid State Drive Replacement, Bottom Cover: step 1, image 1 of 3 Dell XPS 15 9575 Solid State Drive Replacement, Bottom Cover: step 1, image 2 of 3 Dell XPS 15 9575 Solid State Drive Replacement, Bottom Cover: step 1, image 3 of 3
    • For your safety, please make sure the device is powered off and the A/C adapter is unplugged.

    • Use your T5 Torx driver to remove all eight 3.2mm hex screws holding down the back panel.

    • Wedge an opening pick between the back cover and the base of the board, then slightly lift the tool to pop the clips on the back cover off.

  2. Dell XPS 15 9575 Solid State Drive Replacement: step 2, image 1 of 1
    • Make sure all screws are removed before you lift the panel to prevent any damage from occurring.

    • Remove the bottom cover from the device when all sides are free.

  3. Dell XPS 15 9575 Solid State Drive Replacement, Solid State Drive: step 3, image 1 of 3 Dell XPS 15 9575 Solid State Drive Replacement, Solid State Drive: step 3, image 2 of 3 Dell XPS 15 9575 Solid State Drive Replacement, Solid State Drive: step 3, image 3 of 3
    • Use the Phillips #0 Screwdriver to remove a single 3.2mm screw from the SSD Drive.

    • You will know the drive is released when the side holding the screw raises.

  4. Dell XPS 15 9575 Solid State Drive Replacement: step 4, image 1 of 2 Dell XPS 15 9575 Solid State Drive Replacement: step 4, image 2 of 2
    • Carefully slide the SSD from its port, removing it from the device.

Conclusion

To reassemble your device, follow these instructions in reverse order.

2 other people completed this guide.

2 Comments

After replacing the SSD 256GB to 1TB the Power Led started blinking yellow 4 times, white one time when powered by the AC adapter. The internal battery seemes to be disabled somehow. Any suggestions whats missing? Open cover detection maybe? There are no error messages from the bios, windows is running without problems.

micky mouse - Reply

This seemed to be caused by accidentially switching of the little white switch right beside the ssd when placing the ssd into the connector. After switching it on again, it worked as before, no led blinking and running from battery again.

micky mouse -

Add Comment

View Statistics:

Past 24 Hours: 3

Past 7 Days: 5

Past 30 Days: 35

All Time: 1,613