Released October 2008 / 2.4, 2.53, 2.66, 2.8 or 2.93 GHz Core 2 Duo Processor

407 Questions View all

no boot, no light on power supply, no charge on battery

first thought macsafe adapter because it had no light. tried a known good adapter, same. reset pram, smc, tried to boot w/o battery. got the light of adapter ti light, but no boot. exchanged ram modules for known goos ones. same result.

ideas?

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment
Deck the Halls
With tools and Fix Kits

1 Answer

Chosen Solution

I have experienced similar problems with MacBook Pros in the past. I find that it is the DC-In board within the computer. The result of this is that no power can reach the computer therefor it cannot charge, and if out of charge, it will not respond to anything. What you need to do is replace the DC-In board which can be found here:

MacBook Pro 15" Unibody (Late 2008/Early 2009) MagSafe DC-In Board

Now, this may take some work to install but if you are careful and do it correctly, it will most likely (fixed every one I had this exact problem with) fix your problem.

Hope this helps.

Was this answer helpful?

Score 0
Add a comment

Add your answer

gladys mendez will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 4

All Time: 1,754