No response on power up!

Hello!

This is the second iTouch 4g I have repaired. I have made sure to do everything right to the letter. No ripped cables, very delicate, yada yada. Alas, I plugged in the digi and LCD and plugged in the charger for testing....Nothing...Heart sinks.... I tested the LCD on a really crappy beat up and already opened up itouch 4g. Connected the power on that one and it looks great. WTF. I tried again on the new ipod...nothing!?! And also the computer doesn't recognize the connection to the ipod either! ahhh I have checked and double checked my connections/cables! I am open to all suggestions I need help!

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Did it get recognized before the repair? What happened to the iPod that you needed to repair it? What did you replace/repair?

by

Add a comment

3 Answers

Chosen Solution

Well i fixed it! turned out i just had to do a hard restart :) power and home buttons simultaneously for like 30 secs. Thanks man!

Was this answer helpful?

Score 1
Add a comment

I would recommend checking the cables again, but if you are sure that they are on properly, you have probably broken the board somehow.

Was this answer helpful?

Score 0

Comments:

Ya i have been so careful and everything seems fine!! I will upload a macro picture of the assembly soon and you can give me your opinion?

by

Add a comment

guys can u help me after i was boting my device tethered in the middle i unpluged it cause i needed to go after apple logo disapear and nothing works even home and power all combinations doesnt work pls help.

Was this answer helpful?

Score 0
Add a comment

Add your answer

matt wilde will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 743