Skip to main content

The Meta Quest 2 (formerly Oculus Quest 2) was released in October 2020 and is the successor to the Oculus Quest.

172 Questions View all

Quest 2 controller face button suddenly mushy and doesn't work

Hi, so my Quest 2 controllers were working almost perfectly fine, but there was small amount of joystick drift developing. I finally got fed up with it today, and sprayed some DeoxIT D5 electrical contact cleaner in there according to these instructions:

The joystick drift was completely fixed, and I put the black cover plates back onto the controller after some testing.

However, once I started playing a game, I noticed that my X button felt strange. It was mushy and didn't have a clicking feeling, and I needed to press the button quite hard to get it to activate. I couldn't find a video showing exactly how the button sensor is constructed, but it feels like the spring was still working, but the membrane was stuck permanently down or broken somehow, and wasn't clicking up and down anymore.

To get at the buttons it seems I needed to fully disassemble the controller, which I don't quite dare to do at the moment. So instead I decided to spray a bit more contact cleaner into the button and mash it up and down a few times to see if that would help. Instead, the button became completely nonfunctional - it wouldn't activate regardless of how I pressed it. And the mushy feeling remains.

Has anyone disassembled the face buttons on these controllers before? Can you think of anything that might explain the mushy feeling / not working? It was completely fine before I sprayed the contact cleaner, how can liquid contact cleaner affect the button mechanically in this way?

Is this merely the membrane being dirty or stuck, and fixable if I disassemble the entire thing and pop it back out? Or was I just unlucky and the button has failed/broken at coincidentally the same time? I can't find any replacement parts for the buttons, unlike the analogue stick sensors.

Answered! View the answer I have this problem too

Is this a good question?

Score 4
Add a comment

3 Answers

Chosen Solution

I actually know what causes this, and it's that the rubber for the button contacts seems to get damaged by the contact cleaner. I disassembled my controllers to replace the sticks cause of drift, and noticed the rubber for the x button was very damaged and there isn't really a way to replace it afaik without having to buy new controllers entirely unless you can figure out how to make your own. This is what they looked like, they ripped when i tried to get a better look at them but you can see that the outer rim of the rubber is kinda melted a little bit.

Block Image

Was this answer helpful?

Score 1

1 Comment:

Sounds like it's important to keep the contact cleaner away from the buttons, then!

Unless there's alternative brands of cleaner that's safer.


Add a comment

It's likely that the contact cleaner you used has oil in it to protect electronics from oxidation. However, this may be causing an issue in your buttons. First, the oil is likely lubricating the switch inside which keeps it from giving a 'clicky' feeling. Also, the oil is probably on the contact that registers a push, where it may be isolating the contact keeping it from registering a push. Cleaning your buttons with rubbing alcohol may dissolve and wash out the oil and help your problem.

Was this answer helpful?

Score 0
Add a comment

Hello, have you solved your situation? My situation is consistent with your situation.

The WD-40 Specialist Fast Drying Contact Cleaner I used makes my X button cannot work properly. After reading your question, I sprayed the WD-40 into the Y button to test again, and the result was like the X button.

My maintenance tools arrived a few days later. I would like to ask your situation. This seems to be helpful to my maintenance. See you, please reply, thank you!

Was this answer helpful?

Score 0


Hello, I didn't try to disassemble the unit further, I just remapped the button and lived with it (I ordered Quest Pro controllers so I was just holding on until then.)

However, after a few weeks the button mysteriously started working again. It seems the contact cleaner must have caused the button to get stuck somehow, but it unstuck itself.

I don't know if this was sheer luck, or if it was always going to unstick after a few weeks.


Mine did the same thing my buttons work fine now except it still has that light mushy feeling when I press it instead of the hard click like how it's supposed to be, but both my A and B buttons work fine now I'm hoping I can fix it or get a replacement soon


Add a comment

Add your answer

Jeff will be eternally grateful.
View Statistics:

Past 24 Hours: 11

Past 7 Days: 37

Past 30 Days: 147

All Time: 3,190