Model A1136 / 30, 60, or 80 GB hard drive / black or white plastic front

824 Questions View all

Why can't restore my iPod?

when I try Restore in iTunes 9, get message "iPod to busy can';t restore"

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

3 Answers

Chosen Solution

no guarantee, but here's something you could try.

1) try forcing your iPod into Disk Mode first

- simultaneously press and hold the Menu and Center buttons

- the iPod should reboot after a few seconds. Immediately upon seeing the Apple logo:

- simultaneously press and hold the Center and Play/Pause (bottom) buttons

- the iPod should now say "Disk Mode" on top with a check mark and "OK to disconnect" in the middle of the screen

connect your iPod via USB to your Mac (you don't say but I'm assuming you have a Mac??)

then run Disk Utility, select the iPod hard drive in Disk Utility and try to Erase the iPod hard drive. Select Format: Mac OS Extended (if on a PC, just format the iPod as FAT32)

after erasing the iPod, unplug it, reboot it (press and hold Menu and Center buttons)

then plug it in and connect to iTunes, and see if you can restore it now.

2) by the way, did you know there's a hidden diagnostic mode in most iPods? you won't be able to fix your restore-failure problem, but if there some hardware problem in your iPod the diagnostic mode might point out something

to enter diagnostic mode with the 5th gen iPod:

- reset the iPod by holding down Menu and Center button

- immediately upon seeing the Apple logo, press and hold the Center and Previous (left) buttons

- you should hear a beep and see "SVC Diag Boot" on top of the screen

- from there you can press Menu to enter manual tests

- once in the Manual tests, use the scroll wheel and center button to navigate

- under the "IO" subsection you can find various HardDrive tests, including checking SMART status, HD model & serial #, etc. supposedly there is also a Disc Scan test, but for some reason on my 5th gen iPod I don't see that option

Was this answer helpful?

Score 4


thank you bac that worked perfectly!!


WOW it took my 30 mins to find a helpful post like this. You saved us! haha thanks for posting this Bac yayyy :)


Add a comment

If Disk Mode restore doesn't work, then it's either the hard drive or hard drive cable. First, try reseating the hard drive cable. If this doesn't do it justice, then you need a new cable. See the following guide on this.

iPod 5th Generation (Video) Hard Drive Replacement

If it still acts up on a new cable, replace the hard drive with a CF to 1.8" ZIF adapter. However, try the cable first. I have linked both options below, along with a guide. However, should you go with the ZIF adapter you will need to find a way to isolate the board from the rest of the iPod. There's various ways to do it though. It just needs to prevent a short and be ESD safe, preferably. You'll also need an CF card too. Try this 32GB card. Anything larger should work, up to 80GB from what I understand on the 5G board. The 5.5G board goes up to 160GB.

Tape should work for isolation.

iPod Video or Classic (Thin Case) Hard Drive Cable

iPod 5th Generation (Video) Hard Drive Replacement

Here's the adapter.

iPod Video or Classic (Thin Case) Hard Drive Cable Image

Was this answer helpful?

Score 1
Add a comment

I got a picture of a plug when I tried to go into the SVC Diag Boot.

Was this answer helpful?

Score -1


Now I am confused. Is this in response to the question after you did the above steps or is this totally unrelate to the above question and you have a different iPod? Can you give a little bit more detail please???


I'm sorry this is a different person. I am having the same problem and the same ipod. I did what you said but got a picture of a plug when I tried to get into the svc diag. boot. So I plugged it in and the apple logo showed up with a loading bar. I thought it was doing something but still didn't show up in my itunes. I tried later to do the test again and got the boot. Now I'm trying to go through the menu but the battery seems to run down to fast. I am in the auto test right now and am stuck in the..please plug FW. I have plugged it in and out but can't get past. I didn't think you would answer so fast because the post was so long ago. I thank you very much for you help.


Hi there, so what you have done is gone through the diagnostic menu and it hangs up when it checks your FW (Firewire) can you retart or is it unresponsiv? You may have to reset the ipod again , like described in the previous post. When you restart your ipod, do you get the normal apple screen or is it non-responsive? Also you made mention of your battery running down fast. Like really fast? Possible not holding a charge anymore? Do you know how old the battery is? Sorry about all these questions that may seem trivial but I am just trying to visualize what you are seeing on your ipod when it first starts out. MY guess at this time is that you may at least require a new battery and will have to restore your iPod once iTunes recognizes it. Are you on a Window or Mac computer? I have a couple of those 5G iPods and even though they are temperamental I find that once they are setup they are a blast and fairly reliable and easy to fix....let me know:)


Add a comment

Add your answer

Humberto will be eternally grateful.
View Statistics:

Past 24 Hours: 7

Past 7 Days: 57

Past 30 Days: 268

All Time: 38,358