Skip to main content

Charging port doesn't work

Hello! When the device is plugged in via the micro-USB port, the device doesn't charge. Does anyone have any experience replacing the port, or know of any other ways to fix this issue? Thanks in advance.

For info, I have tried several cables, as well as connecting to the mains and to a laptop but in no case can the device be turned on.

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Most Helpful Answer

Hi @es2k6

Here's a video that shows what to try that may help.

Was this answer helpful?

Score 1

2 Comments:

Hi. Thanks for the video. I just tried that, as well as updating the firmware with the bose updater. The device is recognised by the computer but still no way of turning the device on.

by

@es2k6

Here's a video that shows how to disassemble the speaker. This should give you access to the charge port and if you have a DMM (digital multimeter) you can check if the port is OK electrically and you can also visually check for any problems on the motherboard

After that it becomes harder as Bose doesn't release any schematics.

by

Add a comment

Add your answer

E S will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 19

Past 30 Days: 59

All Time: 1,497