Skip to main content

Device repair and troubleshooting guides for the Alienware 17 R2, an American computer made by Dell in 2015, but later discontinued. This product was specifically designed for gaming.

7 Questions View all

Can't boot or run diagnostics

Any OS boot, (Linux/win10/dell diagnostics) from USB DVD hangs. Diagnostics starts but goes blank ( power lights still on) in middle of run. Removed all drives, same result. Windows install media won't complete boot. Hangs. Acronis boot DVD starts, then hangs on Grey screen. Can access BIOS. RESET BIOS no change in status.

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Most Helpful Answer

Four questions:

  1. Have you (re)flashed the BIOS with the latest version?
  2. Taken out and reseated RAM modules and swopped them around? Also run memory test, if possible? It may pin point the error.
  3. Connected the laptop to an external monitor or TV to see if the screen is defective?
  4. Disconnected the battery and tried running laptop from just powersupply/charger?

Service Manual for your information:

https://dl.dell.com/topicspdf/alienware-...

Was this answer helpful?

Score 1
Add a comment

Add your answer

Frank Paulsen will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 54