Skip to main content

This is the first generation of the Ford Escape, a compact crossover SUV. Production started in 2000 for the 2001 model year.

104 Questions View all

ABS & 4WD Service 4WD and Service brake system

Hi there, a slight problem I have with my 2007 Ford Escape 4x4 the ABS light is flashing + 4WD light as well as service 4WD & service brake info messages. Do I need a new tranny? It seems like the transmission has a hard time changing gears.

Any help is greatly appreciated.

Tony

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment

2 Answers

Most Helpful Answer

ABS has nothing to do with tranny, but if it is locking up it may seem like the tranny is having a problem since the brakes are on. It might also be the emergency brake. The ABS would be a sensor/computer issue. The E brake would be more mechanical and easier to check.

Was this answer helpful?

Score 1

6 Comments:

the tranny isn't locking up and neither are the brakes. I will check the ebrake this morning and I am, thinking about taking it in to have it put on a diagnostic system,.

by

i just changed my rear differential and now have all the same lights and coodes

by

@brucenorcal Just to clarify, did you have the lights and codes before you changed the differential, or did they come up only afterward?

by

only after i changed it

by

the ABS light, the service 4x4 and the service brake system all came on after changing the rear differential immediately upon starting car. I should add this is an 07 escape hybrid, awd

by

Show 1 more comment

Add a comment

check your tone rings (speed sensors) on all four drive axels. The tone rings look like a gear on the backside of each wheel assembly and the rings should be solid to the shaft with no play or cracks. Sensors can be tested with a multi meter for volts and resistance.

Was this answer helpful?

Score 0

2 Comments:

i checked all 4 tone rings and replaced all four sensors

by

ive since changed both rear wheel bearings and all four rear control arms and shocks . Car is driveable but at first takeoff the 4x4 system engages and disengages several times before it disables then the car is driveable but feels like abs is surgeing time to time . Service brake system, and service 4x4 warnings still illuminated and abs light on??

by

Add a comment

Add your answer

Anthony Vaneck will be eternally grateful.
View Statistics:

Past 24 Hours: 2

Past 7 Days: 9

Past 30 Days: 28

All Time: 556