Model A1200 with 2.16 or 2.33 GHz Core 2 Duo processor

127 Questions View all

USB ports are dead.

Hi Experts,

All three USB ports are dead. System boots but I can't get any response from the keyboard or mouse. I opened it up and noted that all 4 LEDs are lit. Did a SMC reset and tried to force a PRAM reset by removing the clock battery to no effect. Disconnected the hard drive to force the system to boot from the installation DVD. System boots to the first screen asking me which language I want to use but of course I can't input an answer. A cheap optical mouse glows when I connect it to any of three ports so there is power. I conclude that part of the logic board has failed. That being true how do I get the installation DVD out?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

I had a stuck install DVD in my machine (which was dead at the time). I used a pair of surgical tweezers with ends wrapped in duct tape to ill it out of the drive. (They use something similar at The Apple Store) It worked easily and I didn't even scratch the disc. You could also try booting with the mouse button pressed which may work if it is drawing power from your Logic Board. Good luck.

Was this answer helpful?

Score 2
Add a comment

Add your answer

John H will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 616