Skip to main content

Released in October, 2015. Identified by Model Number GL752VW-DH74.

19 Questions View all

Laptop doesn't boot into bios or windows

  • #1

I wanted to re-install my windows after dual booting xubuntu.Therefore after removing the partition,I reset the bios,enabled legacy devices, and then tried restarting into the usb.

But now the laptop is just stuck in splash screen and cannot even boot into bios. Please Help!!


Laptop:ASUS G752vy CPU: i7 6700HQ GPU:Nvidia GTX 980M

Answer this question I have this problem too

Is this a good question?

Score -1

2 Comments:

Hello,

Try using external keyboard and see if you can boot into BIOS by pressing F2.

by

I've tried it, and cannot seem to boot into bios.

by

Add a comment

1 Answer

@retr0_2000 …reflash your bios. can find instructions and file on manufacturer website. then reinstall windows.

Was this answer helpful?

Score 0

2 Comments:

How do I go about flashing bios without booting into bios?? Do I need to open up the laptop??

And can you please link the site if found, it would really help.Thank you.

by

here is a link to the current bios for your listed motherboard.

https://www.asus.com/us/ROG-Republic-Of-...

you will have to get into the bios to reflash. have you tried shorting the cmos terminals to reset the bios and check if it boots? here is a guide:

https://www.asus.com/support/FAQ/1040820...

by

Add a comment

Add your answer

Pramith L will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 27