Second generation of iPhone. Model A1241 / 8 or 16 GB capacity / black or white plastic back. Repair is more straightforward than the first iPhone. requires screwdrivers, prying, and suction tools.

1496 Questions View all

My phone continuosly displays the apple logo, after moments of charge?

After charging the Iphone, the apple logo continuously appears and disappears. Why is the phone locked in this mode? No error codes come up. Changed the battery and the phone is doing the same thing. Can't shut the phone down with the power button.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Black Friday
Broken doesn't stand a chance.

3 Answers

Chosen Solution

you are stuck in recovery mode? does itunes recognise your phone? if not i believe this is something to do with the power management chip...it isn't functioning fully to allow your phone to boot up to full working order. The error code only appears if you try to restore your phone in itunes...it will most likely be an error in the 20's.. you can have that chip replaced by a good repairman.

see what happens if you try and restore..you could try iReb or tinyumbrella to see if that will help get you out of the boot loop

Was this answer helpful?

Score 2
Add a comment

i have a same situation. It was a new iphone 4, just bought it from Singapore & without any ios inside. The Apple Store guy told me to restore by ourself. I tried many times but in vain.

My situation is the Apple logo just appears & reappears after couple seconds. If i'm not mistaken, it is called Apple boot logo loop, which can't allow me to boot up or even restoring/updating. When i tried to restore, it just appeared this Apple logo repeat & repeat, not allowing me to install the ios. It is because the iTunes said "Preparing to Restore" for liked forever!

Hopefully there is a kind soul who can help me to fix it. I live in East Malaysia, by the way. It is not that easy for me to go to Singapore to change it...

Was this answer helpful?

Score 0
Add a comment

have you tried hard reboot? press and hold home button + power for 15 seconds until you see the apple logo. release the home and power button if you see the apple logo, and wait till its boot. hope it helps.

Was this answer helpful?

Score 0
Add a comment

Add your answer

stcbllng276 will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 8

Past 30 Days: 29

All Time: 5,180