The Roomba Red 4100 is a vacuum cleaner robot produced by iRobot that can clean a room all on its own.

12 Questions View all

Cleaned machine, still not working?

When I turn my roomba 4100 series on, I get the 4 beeps, which indicates that a wheel motor cannot run. I have cleaned all parts and removed any debris. It still beeps 4 times. There seems to be nothing stuck around the wheels or brushes. Help!

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

nicole, turn it over and look for something caught in the wheels. Test wheels by pushing them in and out and making sure they rotate freely. Of course, if you have already tried that and it did not give you any results, then you need to try to run the self diagnostics. Here is link link to a really good site that will show you how to run diagnostics on your Roomba. It should help you to narrow your error down. Also check this link for more info (you are not alone with that problem:-) download the service manual from here. Make sure you save it, apparently iRobot does not like us to look at their manuals :-) Good Luck

Was this answer helpful?

Score 2
Add a comment

how to reove battery how to charge

Was this answer helpful?

Score 0


davidgetchen, click on the link on the right side of this screen "Ask a question" and give as much DETAIL as possible for your ROOMBA. Model and serial numbers are very important as well as letting us know what you have tried to fix it. Also let us know what the symptoms are :-) and if you have tried the user manual yet.


Add a comment

Add your answer

nicole will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 3

All Time: 2,304