My MFC-J5720DW Printer won't connect to computer via wifi

I recently upgraded my very old wifi router to a new cable modem/wifi router combo unit that supports both 2.4 GHz and 5 GHz channels. I’ve set both the computer and printer to run on the 2.4 GHz channels, as I’ve read that Brother machines can’t use 5 GHz channels. I uninstalled the previous Brother drivers and hardware installed on my computer, and then via the brother website downloaded the full driver/hardware suite for my machine. I’m able to run the setup for wifi until it asks to setup the wifi network on the printer itself, which I do, and then nothing happens and I can’t complete the setup process for wifi and ControlCenter software. I’ve only been able to get everything to work (print and scan from/to computer) by using the USB cable, which is a pain in my desk setup. Any advice or help on getting the wifi connection to setup properly and work would be greatly appreciated. Thanks!

Answer this question I have this problem too

Is this a good question?

Score 0


Hi @tahoemama80 ,

What is the make and model number of the modem/wifi?

Can you successfully connect other devices via wifi to the modem /wifi?



It's an Arris SBG7400AC2 DOCSIS 3.0 24 x 8 channels. I have all my office computers and the printer connected to the 2.4 GHz connection, and devices, such as smart TVs, are on the 5 GHz connection. No issue with the computers or the other devices.

I can sometimes get the computer(s) to connect to the printer on the WiFi network via the Microsoft Windows 10 "add device" feature under Settings, but from there I can only print pages, the scan function doesn't work. This means that the Brother printer is connecting to my network. I really need the scan function to work. And in the past I've only been able to get the scanner to work via the WiFi network connection if I can successfully setup the Brother ControlCenter software and drivers onto the computer.

Thanks for your help.


Hi @tahoemama80 ,

Assuming that the printer connected to the WiFi modem OK (did you try using the printer's control panel?)

Is the printer showing up when you go to the computer's Control Panel > Devices and Printers?

Have you tried running the printer troubleshooter? Go to Settings > Update & Security > Troubleshooter > printer.

Also if you do manage to connect to it and print OK but not scan try using the Windows Fax and Scan program.

Click on the Windows Start button on left side of Taskbar and type fax and scan in the search box. When the options menu opens click on the Fax and Scan App for the PC.

The reason I suggest this is that I too have a Brother printer and whilst it is not a wireless connection it would print but not scan whatever I tried when using the Control Centre software but it will scan using the Windows Fax and Scan software. Worth a try if you can get it to print but not scan


Thanks for the suggestion. I actually did the "Troubleshooter" on the printer last week, which came up with nothing. But the Windows Fax and Scan App does work for scanning documents on the Brother printer.

The printer just doesn't want to scan from the control panel on the actual printer. It doesn't pickup the computer as connected, even though I just printed a page from the computer via WiFi.

What a pain! I may see if there's any firmware updates to do from brother.

Thank you for time and suggestions, much appreciated.


Add a comment