Skip to main content

Fix Your Stuff

Right to Repair

Store

Repair guides for the MacBook Air, Apple's current line of consumer laptops.

4432 Questions View all

Multiple MacBook Air 2011 problems, doesn't boot or recognise SSD.

My apologies for the long post, but figured I’d give more than less in the hopes of getting better feedback and you would not need to ask as many questions. I did search the MBA questions and did not find anything that addressed the problems I’m having.

Background

I bought this laptop about 2 ½ years ago off our local auction site to use for parts to fix a friend’s broken MBA, but the friend decided not to go ahead with the repair. I put the laptop aside and forgot about till a week ago when I saw it and thought I should have a try at getting it going.

I don’t know anything much of its history except the vendor (claims to) get a lot of stock as insurance write-offs. This one was liquid damaged and has had the SSD removed. It was also stated that the laptop turns on with the question mark folder and the keyboard is faulty. Battery is holding a charge.

I figured the question mark folder was because there was no SSD.

My plan was to attach a external HDD and keyboard to test it. When I got it I did that and managed to get it to boot off an external USB HDD but it wouldn't do it reliably, so didn’t get very far. Eventually, due to time pressures I had to return the friend’s still broken MBA, as she decided not to proceed fixing it.

In hindsight, this MBA was not a good parts machine, and if I knew then what I know now I would not have bought it.

Over the time I have read more and successfully fixed some things with some MBPs. and now that I have pulled it out and done some more testing on it, these are the things I can say about my MBA.

The problems

I worked through the MBA Troubleshooting Guide. At the moment I have unplugged the battery (for reasons I’ll get to). So in the same order as the guide:

  • The laptop powers on. When I connect the power cable, after about 5 secs it starts and chimes. I don’t need to press the power button.
  • The RAM appears to be good – it does not beep three times (or beep at all);
  • Power adapter is good, the laptop runs on mains and the battery appears to take a charge.
  • It may now have a thermal sensor issue now (but didn’t when I first got it) as the fan ramps up and runs fairly fast, don’t think it is running full speed.
  • Probably does not have a dead battery, as when I pull the power off with battery plugged in, it does not shut down immediately. I haven’t left it on to charge because pressing the power button does not shut it down and I don’t want it running with the fan on a high speed.
  • The flashing question mark folder comes up, after about 30 secs. Nothing else can be done.
  • Not a bad operating system. Since I wasn’t able to get the alternate disk boot selector to come up or get into recovery mode, I purchased an SSD and have confirmed it is correctly formatted and bootable with OS X 10.12. But the laptop does not recognise that it is there.
  • I don’t think it has damaged RAM, but no real way to test it (no beeps on boot up though).
  • Not a bad SSD. I have installed the SSD in an enclosure tested it on a MBP, and it boots fine into OS X.

That is as far as I can go in the troubleshooting guide.

Further Information.

Interestingly, I cannot see any sign of liquid damage on the logic board.

Over the time I have tried to reset the PRAM and the SMC (probably several times), but with an external keyboard I’m not sure whether it worked.

In reading about unresponsive built-in keyboards, saw that you need to disconnect the built-in keyboard, so I did that and now, with an external keyboard connected, when I press the option key I now get the EFI lock screen. 8-(.

With the power cable disconnected and the battery plugged into logic board, nothing happens when I short the power pads on the logic board. (The built-in keyboard is still disconnected.)

Given the above, is it a reasonable to conclude that the logic board and the keyboard (at least) need to be replaced? Can anyone see anything else I should be testing while I have it apart?

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Most Helpful Answer

That MacBook is a paperweight unless you know the password for the EFI lock screen.

Was this answer helpful?

Score 2

Comments:

I realise the problem there, but was curious how it did boot from the external drive at one point, but now it has an EFI lock. Also, when it did boot from the external drive, I didn't press the option key, it just booted off the external drive. It doesn't do that now, btw.

Also, if I go ahead fixing this machine, I will more than likely be replacing the logic board, so the EFI lock is a moot point, yes?

by

Add a comment

Hi Josh !

I suggest you try the following actions:

  • Turn off your Mac
  • Change the RAM configuration (remove a RAM for example)
  • Maintain CMD-ALT-p-r (this allows you to skip PRAM and NVRAM)
  • Start the machine
  • Wait for the 3 "Gongs" and release the keys
  • Once this is done, the EFI password has been skipped and you will have access to your Mac normally

Was this answer helpful?

Score 0

Comments:

I am aware of this procedure and unfortunately it is not possible on an Air, as the memory is not removable. It is soldered directly onto the logic board.

by

@jobiwan16

I'm sorry, I didn't pay attention to that detail. It will therefore be difficult to recover it.

by

Add a comment

Add your answer

Josh will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 56