Skip to main content

Fix Your Stuff

Right to Repair


2nd Generation high performance tablet computer released by Apple on June 2017. Model A1670.

24 Questions View all

I updated my iPad Pro 2nd Gen to iOS 12.1.1. Now device won't charge

I updated my iPad Pro 2nd Generation, now it wont charge.

The update did a hard reset, I could download diagnostic as battery life was to low, It said the Device is in excellent condition and can’t explain whats happen and its out of warranty so cannot be replaced.

Answer this question I have this problem too

Is this a good question?

Score 2


have ios 13 install the barrary will not charge


iOS 13 Oct 2019 bricked my A1671 iPad Pro Wifi/Cellular - won't respond to iTunes after putting it in DFU mode.


Add a comment

3 Answers

Most Helpful Answer

Have you tried doing a full device restore through Itunes?

Was this answer helpful?

Score 1
Add a comment

If possible, you should use the wall adapter that came with your iPad to see if it charges with that. Some of the new iPads have more specific wattage requirements to charge properly. It’s always best to use an original Apple charging cable or “made for iPad” certified cable when diagnosing charging issues as well.

Was this answer helpful?

Score 1
Add a comment

I brought a new cable and charge at BestBuy and still no charge

Was this answer helpful?

Score 0
Add a comment

Add your answer

danman73 will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 5

Past 30 Days: 18

All Time: 523