Second generation of iPhone. Model A1241 / 8 or 16 GB capacity / black or white plastic back. Repair is more straightforward than the first iPhone. requires screwdrivers, prying, and suction tools.

1492 Questions View all

After replacing battery now Camera doesn't work

Having really bad luck, after replacing battery now the camera doesn't work. When I open the app the shutter doesn't open. Bought a camera on an auction site and it's doing the same. Now I really don't know if the camera is also bad or whatever is broken. I did all the resetting available including hard reset and restoring the phone.

What should I do? Thanks!

Update

Just bought a camera on eBay and now is working great!

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

great news, glad you fixed it

by

i have exactly the same problem. any help would be very appreciated.

by

Add a comment

7 Answers

Most Helpful Answer

check the little metal plate that holds the camera in place is making contact with metal and not the rubber pad protecting it.

Was this answer helpful?

Score 1
Add a comment

YES!!! WHOO HOO! What worked for me is to take the motherboard right out and unhook the camera, and then connect the camera to the mother board when it is out so you can get a better view and access to it. That way it is much easier to make sure that the camera has a good connection to the motherboard. Then place the motherboard and the camera back on together. It worked For me after having the same camera problems after installing a new battery.

Hope you have the same good luck as I did. GOOD Luck To Ya!

Was this answer helpful?

Score 1
Add a comment

i have the same issue after replacing the battery the camera no longer works.

Brought a new camera module but its still doing the same thing.

Tried restoring, rebooting, hard powering nothing seems to work.

When i load the little camera program the shutter is closed and the icons for the camera switch to video flashes.

I thought perhaps the pins that the flexi cable plugs into might be damaged but that doesn't seem to be obviously apparent.

next option will be to take it to an apple fix shop and hope they can sort it.

Was this answer helpful?

Score 0
Add a comment

hey....an solution??? I have same problem...after iphone demonting camera doesnt work...I tried it reconnect 4 times but not lucky :(( shutter still closed but i can switch between camera and photocamera...help please

Was this answer helpful?

Score 0

Comments:

is this an iphone 4? different problem if it is. Please ask your own question.

by

Check the update in the original question "Update

Just bought a camera on eBay and now is working great!"

by

It´s iphone 3GS...it is possible I have damaged flex cabel to camera...I will try to buy new one camera before I will visit any service place. On the photo there is some dirty...I have cleaned it, but no progress ::-) http://rogerer.rajce.idnes.cz/nastenka/#...

by

good photo. is that white "thing" on the motherboard connection/pin the part that won't clean? or is that gone? try new camera and see what happens..the wires inside the flex are incredibly thin, a little too much force or maybe twist/bend and they can break.

by

no, all pins seems to be ok. In case only a little to much force can break wires...I am pretty sure it´s break :-) I will try a new camera....

by

Add a comment

Verifying the plate/pieces is screwed in properly and making contact seems to be a fix. It must work itself loose after a while though because I have had to do this a couple times. But I can confrim this works unless this is an unparralelled coincidence each time I verify it is tight and making contact.

Was this answer helpful?

Score 0
Add a comment

I did the steps suggested by JeffreyV1 and it worked out!!

Thanks for sharing this @JeffreyV1!! Now my camera is back again!

So the problem for me was that the camera wasnt connected to the motherboard. These very small "metal surfaces" that connects the camera to the device have to be connected correctly. Somehow this didnt happend when i just tried to screw back the motherboard, after replacing the battery.

Here is a step by step guide of what I did to get it working:

1) Remove the motherboard and take it out of the case.

2) Remove the camera by removing a screw on top of "the camera box" (this is the screw that presses a little metal plate toward the surface)

3) Now, gently, try to remove the camera and place it next to the motherboard.

4) Connect the motherboard with the camera. This was a little tricky, (make sure that it is pluged in correctly)

5) Now take the whole package (that is the motherboard connected with the camera) and place it back in the case, push the camera back in its correct position. Try to get the motherboard to match the screw holes .. It´s a little tricky to get it in exatly but with a little patient (and a little force=) it´s gonna work out.

6) Then it is just to get everything together and hopefully your camera is working as well!

Good luck!

Was this answer helpful?

Score 0
Add a comment

this worked perfectly and fixed my camera. thanks

Was this answer helpful?

Score 0
Add a comment

Add your answer

Pochoco will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 13

All Time: 7,981