Skip to main content

This computer was released by Asus in 2014.

39 Questions View all

USB ports charge devices but doesn't recognise them

My laptop has two USB ports and both of them provide power to my devices (eg cellphone, tablet, flash drive, etc). However, when plugged in, these devices don’t appear/work on the computer. So I can’t access my files or use my drawing tablets. This happens quite often to me but I can usually get everything working again by disabling the USB controllers under Device Manager and then enabling them, or by waiting a few hours. Nothing seems to be working this time, though. Any suggestions/advice is appreciated.

List of things I’ve tried:

  • Restarting laptop (every time I did one of the following)
  • Removing power cord for a few hours
  • Changing power management settings for USB Root Hub (USB 3.0)
  • Turning off fast startup
  • Uninstalling hidden devices
  • Checking for outdated drivers (DriverEasy didn’t detect any)
  • Scanning for hardware changes
  • Removing dust from USB ports

Also, I have this error in my Device Manager. It’s been there for a long time and never affected anything but I thought I’d mention it just in case.

Block Image

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

iPhone Battery Fix Kits

Only $29.99

Buy Now

iPhone Battery Fix Kits

Only $29.99

Buy Now

1 Answer

Chosen Solution

Hi @forestial ,

Don't know your laptop, but did you check in BIOS in case there is a setting which enables/disables inputs?

Here's a link with the latest Asus Win 10 drivers perhaps you can check if yours are up to date, especially the USB 3.0 driver

Was this answer helpful?

Score 1

Comments:

@jayeff I just enabled it in BIOS and it worked. Thank you for your help.

by

Add a comment

Add your answer

Micah will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 46