Skip to main content

The Asus X551CA is a 396.2 mm laptop computer with convenient features for everyday use.

29 Questions View all

Why can't I see the SSD connected via USB port under "My Computer"

Hi all,

I decided to upgrade my Asus X550CA laptop with a Crucial SSD. I wanted to clone my existing hard drive however when I connected the SSD to my laptop via USB connector, I could not find it under My Computer.

I have tried to find am answer with no luck. When I go in disk management I can see the new SSD there in the bottom half. At the top half i see only C: and D: drives. Also, the driver for the new SSD is installed because I can see the SSD in Device Manager and I can elect it to unplug. So it seems that windows is not assigning it a drive letter. I have windows 8.1.

Has anyone one had a similar issue?

Thanks in advance,

GA

Answered! View the answer I have this problem too

Is this a good question?

Score 2
4 Comments

I am using EaseUS.

by

By the way, it is the free version of EaseUS. By initializing the disk do you mean I have to partition it?

Thanks

by

What if it states “NO Media” for the drive under Disk Management? I have already assigned a letter for the drive.

by

Hi @Elisha Satterfield

I suggest you start a new questions with more details to be noticed.

by

Add a comment

3 Answers

Chosen Solution

Actually I got it to work after watching a you tube video. In case someone runs in similar issue, the SSD needs to be initialized. I went in Disk Management, where my SSD showed as unallocated. Right click on it and choose New Volume. Then in the window that pop up check assign letter drive, format and that's it. Worked for me.

Was this answer helpful?

Score 13

6 Comments:

This worked. Make sure you assign the drive letter or it still won't see it.

by

Thank you ^^ thought my cheap amazon cable was defective!!! <3

by

Thanks so much!

by

This worked with my new SSD Samasung EVO 870. This simple short suggestion was all that I needed after seaeching dozens of quasi complex suggestions on Google. Thank you author

by

same as above new evo 870, ty so much!

by

Show 1 more comment

Add a comment

Hi genti agastra , i suppose it is a new SSD, yes, if you see in disk management on the SSD device, means your SSD is detected on the computer.

The reason you are not seeing the Drive letter, is most probably, the disk is not initialized yet.

what software do you use for cloning?

most cloning software should be "smart" enough if you start the cloning, it will see this new SSD drive as the destination

Was this answer helpful?

Score 2
Add a comment

Do you use the correct usb Cable?

Sometimes you need a two port Power usb to get the correct Power to the hdd.

Was this answer helpful?

Score 1

1 Comment:

I have tried two types of USB to SATA connectors. I am pretty sure that is not the problem

by

Add a comment

Add your answer

genti agastra will be eternally grateful.
View Statistics:

Past 24 Hours: 15

Past 7 Days: 74

Past 30 Days: 396

All Time: 44,008