Won't charge, but works on battery

Hi folks,

I had a bit of an incident a few weeks ago where 2 of my computers died at the same time. I suspect a power surge but not entirely sure, since I was also tinkering with a small development board that was attached to my desktop at the time. The desktop (PC) had it's motherboard fried (and replaced by now) - mentioning it for context.

The MacBook Pro had turned off. I had then tried turning it on, and it turned on for a second or so then shut itself down. I tried turning it on again, this time it worked, with all the date/time reset, but otherwise working well. That's when I noticed the battery is not being charged. The computer was running fine for a few hours on battery power only. I initially thought it's just the MagSafe power adapter so I went ahead and bought a new one. When the new one wouldn't charge either, I took it in for repairs. The shop said it's either the motherboard or the IO board that's fried, that they tried replacing a fuse, but it didn't work. They also said that since my Early 2011 MacBook Pro 15" is now in "vintage mode", they couldn't get official parts from Apple anymore.

Does anyone know if just replacing the charging board would work, or does it sound like the motherboard is gone too? I'm happy to disassemble and post pics, here's one that just shows the relevant area close to the charging port.

Block Image

Thanks in advance for any tips & suggestions!

Answer this question I have this problem too

Is this a good question?

Score 0


What does the battery symbol show when the charger is plugged in? An X on the battery symbol, the percentage saying "X amount of time to fully charge" when clicked, or the percentage but saying "not charging"?


Thanks for the help @reecee

The battery doesn't have any charge in it left, but from what I remember, there was no X on the battery symbol. The battery symbol looked like as if I didn't have the charger plugged in at all (ie. looked like the normal "running on battery power" symbol).

Perhaps I should mention that the charger cable itself never lights up. The orange/green light that usually comes on when plugging in the charger to the computer doesn't turn on. It looks as if the charger weren't working at all, but I know that is not the case as I tried with a new one, and also the tech at the repair shop said the old charger works well.


Have you tried resetting SMC? With the Mac plugged, press and hold the Shift, Control, Option, and Power buttons for a moment before relasing. If it works, the MagSafe LED will light up.

If resetting SMC doesn't fix it, it is probably either the MagSafe DC-in Board or the Main Logic Board. There's no way to be 100% without testing/replacing parts.

If it was my computer, it's a time-consuming repair; but I'd try the MagSafe replacement since it's an inexpensive part $24.99 MacBook Pro 15" Unibody Early 2011 MagSafe DC-In Board Replacement

A new Main Logic Board is considerably more...


I did try resetting the SMC, unfortunately it didn't work.

At $25 it's not too pricy of an attempt. If no one else chips in with other advice soon, I will probably go ahead and do that.



Yes try a known working charging port. If it’s not lighting up (even with the battery unplugged) the issue is board related.

Can guide you if you have tried a good charging port and have the tools/experience to solder


Show 1 more comment

Add a comment