Released in October of 2014. This model, SM-G530H/DV Samsung Galaxy Grand Prime, comes in a White, Gray, or Gold casing.

106 Questions View all

Why doesn't my Samsung device recognize the micro SD card I install?

On my Samsung Galaxy Grand Prime, Model#: SM-S920L, why won't it recognize when I install a micro sd card for expanded memory? I've tried an HC 8Gig card as well as a Samsung brand 32Gig card but it won't read that there is a card in there at all. Is the reader damaged? The prongs of the reader have to meet the pads on the sd card, right? So maybe the prongs are bent? How can I fix this issue PLEASE!

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
New Battery = Faster iPhone
Fix Kits starting at $16.99

2 Answers

Chosen Solution

The phone appears to be dual sim, with the main sim reader having a microSD reader at the top.

My guess is the microSD card reader pins have been damaged or bent.

Unfortunately if this is really the case a new one would need to be resoldered on.

Not much people would do this as a rework station is needed, if you can find someone that does micro-soldering they can do this for you.

I think you should be able to visually inspect for damage easily with the use of a microscope and looking into the slot with a light source.

Was this answer helpful?

Score 1

Comments:

Thank you, Ben. I appreciate that. Is there no way of simply bending them back into place if they've just been bent?

by

Yeah you can with tweezers but you would have to be very careful, bending them back too much may cause one or more of the pins to break off.

by

Add a comment
Most Helpful Answer

Hi,

Just double checking that you have inserted the card(s) until they 'click' into place and that to remove the card(s) you have to push it in further so that it springs back out.

Also have you tried mounting the SD Card?

Go to Apps > Settings > Storage > tap Mount SD card.

Was this answer helpful?

Score 2

Comments:

Thanks Jayeff, for your response. I have inserted the cards fully each time and the option to Mount SD Card is grey'ed out in the settings. That's my problem. The phone doesn't recognize that one is present when it clearly is.

by

Hi,

Has it worked before OK?

My only thought is to try a factory reset just in case it is a software glitch that is causing the problem and not as you are probably correct in saying that it is a hardware fault. Initially it is less intrusive than having to open the phone and possibly causing more problems

If you do decide to try this remember to "back up" the phone first. That way when you wish to restore the phone after the reset has either proved or disproved whether it is hardware related or not you can go back to where you were before you started.

by

Add a comment

Add your answer

Grayson will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 3

Past 30 Days: 55

All Time: 55