My lenovo a7000 won't charge and the computer is not recognizing it

So last night my phone had only 5% battery left so I decided to charge it in when I woke up at 3AM. Then when I woke up later in the morning there's no sign in my indicator that my phone is charging.

I already held the power button for a minute and cleaned the plug of my battery and plug it again in the charge but nothing happened. I tried another charger but it nothing happened too!

But when I tried the charger with other android phones they're charging. When I plug it in our computer the computer is not recognizing it.

What should I do? Need help. I can't factory reset it too.

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment
Black Friday
Broken doesn't stand a chance.

2 Answers

Most Helpful Answer

@lexylexander23 since you tested the charger on other phones, it does sound like it is working. Since it does not charge your Lenovo, I suggest that you start with installing a new battery. After that you will need to investigate the charging port on a board level and see if it is getting the voltage it needs and if it is connected. Power management IC's will be the last ditch effort. For any of those test you will have to disassemble your Lenovo this video should help you with that. Take a few images of the logic board etc. so that we can see what you see. Add those to your question by following this guide Adding images to an existing question

Was this answer helpful?

Score 2
Add a comment

try to buy a new charger

or, repair the charger

Was this answer helpful?

Score 0

Comments:

@ctaneshaa read the compete question "when I tried to the other android phones they're charging."

by

Add a comment

Add your answer

Dera will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 10

All Time: 48