Announced on October 16, 2014, the iPad Air 2 is a thinner successor to the iPad Air.

183 Questions View all

Stuck in recovery loop after attempted update.

After the release of ios11 I backed up my iPad on my MacBook Pro and downloaded the update. The update process started, and then the iPad restarted and I got an error in iTunes. The iPad stayed at the Apple logo and wouldn't change. No big deal, I thought. I just backed up. Just restore and go from there.

I did a hard restart, and the iPad loaded to recovery mode with the plug into iTunes information. I plugged it in and iTunes prompted me to restore or update. I tried updating again, which returned with an error 9, and the iPad just restarted to recovery. I tried restoring from a Windows computer with the newest version of iTunes with the same error. Created a new user on my laptop and tried... same error.

Then came DFU mode. iTunes recognizes the iPad, restore starts. The iPad restarts and gives the Apple log and an empty progress bar. iTunes says verifying update, then the iPad restarts, and I get error 9 in iTunes.

At this point I've gone through everything I can find in forums for suggestions, and have even tried some of the apps that claim they can fix these issues. All with no success.

The iPad is cared for pristinely, and has been working flawlessly until this update. Is it bricked for good at this point? Hoping not... can't really afford to replace a perfectly good device.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

I would try to manually download the IPSW for iOS 11 separately.

You can download from here.

Once you have downloaded this file, launch iTunes and put the iPad in DFU mode again.

When you plug your iPad in as DFU, it will ask you to restore. Select "no".

You will then be shown a screen with a "Restore" button

• on a Mac, hold "Option" key down + Click the "Restore" button. Then select the manually downloaded file from above.

• on a Windows machien, hold "Shift" key down + Click the "Restore" button. Then select the manually downloaded file from above.

As a last resort, use 3uTools to flash the firmware.

Was this answer helpful?

Score 1


Thanks for the suggestion with 3uTools! Nothing else would work, and it failed on one computer with 3uTools, but worked fine from another. I've noticed now that when plugging my iPad back into my Macbook it will connect and disconnect repeatedly every second or so, and won't get picked up in iTunes. Connected fine to a Windows computer, but acts as though it wants to try charging rather than connecting with iTunes on my laptop. Even after charging it completely.


Hi @therepaircenter, does this connect/disconnect problem occur on all the computers or just one? Do you have multiple cables to test with?


It seams to only be on my Macbook. I've tried several cables as well as the USB ports on either side. My iPhone connects fine with no issues using all three cables I tested with. Also created a fresh user account to try to rule out something there and it still happened with the iPad.


So it sounds like the USB port itself has issues. You may want to post a second question in the forum on fixing the USB port. @danj would be likely the best person to assist on this issue.


Add a comment

My sister gave me an iPad air that was stuck in this sort of "Error 9" loop. She told me something about it freezing during and update and now, this. I messed with it for weeks, googling and reading and even got close to paying for a few (likely scam) programs that promised to fix it. Then I came across this useless youtube video

And for the first time in my adult life, a YouTube comment actually had value. Mr Jose Brun suggests to plug something into the headphone jack while performing a restore through iTunes. Like any of you, I rolled my eyes. But also, it's easier than taking it apart and looking for hardware to fix.

It worked. I honestly barely believe it myself, but the iPad is back and working. So if you're tinkering with this kind of problem and your iOS device still has a 1/8 inch connector, plug something into it and see if that fixes it.

If anyone out there knows why the heck this worked, I'd love to know.

Was this answer helpful?

Score 0


Hey timasher. I'm confused. I bought this iPad Mini 3 from the pawn shop for REALLY cheap bcuz the power button was stuck down. But that was ok cuz the ipad worked just fine. Yet it needed the update bcuz it was still on iOS 10 . When I went to do the update it stated to go then got stuck in this loop where it just keeps showing the Apple logo over and over and over again but never boots back up. I assume this is cuz of that power button being stuck down.. Now I understand how you plugged something into the head phoneJack. But what I don't get is how did you get it into restore mode for iTunes with the power button not working? The only way I know how to get it into restore or hard reset mode is holding down the home button and the top power button? When I plug it in. It just wants to charge like normal but doesn't turn on either... I haven't hooked it u to a Mac yet to try charging it. This really sucks I just bought it and had it 15 min haven't even used it yet.



Add a comment

Add your answer

stephen will be eternally grateful.
View Statistics:

Past 24 Hours: 73

Past 7 Days: 314

Past 30 Days: 1,194

All Time: 2,713