The Trio Stealth G4, manufactured by Mach Speed Technologies, is a touch screen tablet with a 7.85” HD screen. The device has Wi-Fi, Bluetooth, and Google Play capabilities with features that include a quad core processor, and front and rear facing cameras.

14 Questions View all

Why won't my Stealth G4 charge?

I bought my Stealth from a local Pawn Shop before Christmas 2016, and it's always worked great. I bought the 90 day warranty. The charger has always been a little loose when we've plugged it up to charge, but it's still charged with no problems whatsoever. It's been about 10 months now, and all of the sudden nearly a week ago I plugged in the charger, and it would not charge. I tried several other chargers in our home, and it still would not charge. I tried to wiggle it slightly since it's loose... Nothing - no luck! What's wrong, can it be fixed and if so how difficult is this going to be?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

Free shipping on all orders over $100 or containing a Pro Tech Toolkit!

Browse Our Store

1 Answer

Chosen Solution

@kashley1986 this "The charger has always been a little loose" sounds like a bad charging port. It is totally possible that this is now wore out to the point of no longer working, or it may have come of from whatever board it is connected to. I'd be checking the connector by taking the tablet apart using these guides and checking the port.

Was this answer helpful?

Score 2
Add a comment

Add your answer

Kristen Leonard will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 4

Past 30 Days: 20

All Time: 137