Wired controller for the Xbox 360 console.

11 Questions View all

Afterglow glows, but doesn't work

Hello, I have bought an Afterglow Wired Xbox360 Controller about a month ago and plugged it to my PC with Windows 10 64-bit. It was working perfectly, glowing and rumbling, I was playing Dark Souls. Then I went with my family for about 2 weeks, and came home 2 days ago. I tried with The Witcher 3, to see how would it work with Afterglow, and worked without problems.

Today's morning I plugged my Afterglow, and it's glowing green by all LEDs, but Guide Button doesn't, and whole controller isn't working, neither with Souls nor Witcher. Windows doesn't beep when I plug or unplug it, doesn't see it at joy.cpl, Device and Printers or Device Manager, controller just glows green so he must be powered-up. I tried with USB in front and back of PC, still only glowing. Same problem with my friend's PC and Xbox 360, just glowing, not working. Could you help me?

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Problem solved!

I opened the Afterglow, clean it up from dust and plugged, again just glowing.. While packing motherboard into xbox case, I thorn off the RB-sibe vibration motor by accident. I wanted to see if anything happend, plugged it to PC and it start working! Maybe glowing Afterglow means "problem with motors" or something like that.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Stanislaw will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 19

Past 30 Days: 60

All Time: 761