Acer's 15.6 inch E5-571 series laptop manufactured in 2014.

31 Questions View all

My Laptop won't turn on

My device is no longer starting! When I plug the charger to the device the orange light appears naturally. But when i press the power button, the blue light goes on for a second and then the blue and orange lights goes out together. I thought the problem was with the Ram card , so I installed another card and changed their place but also no result!

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

Free shipping on all orders over $100 or containing a Pro Tech Toolkit!

Browse Our Store

3 Answers

Most Helpful Answer

This could be an host of issues any one of which can cause this so lets start with the basic. remove the laptop battery and disconnect the power then hold down the power button for 60 seconds. then reinstall the battery and plug in the power and boot the laptop. if it works it was a case of static discharge if there is no joy lets move on to the ram . Remove one stick of ram and try to boot the laptop if it doesnt boot then move that stick to a different dimm slot. and try to boot again if the laptop boots it means one stick of ram was bad if not then switch out and test with the other stick keep trying until you have tried each dimm in each slot . If you have no joy then we move on to the APU. try pluging in an external monitor. If it works then your LCD screen is bad and will need to be replaced if it doesn't work then the issue is probably with the GPU

Was this answer helpful?

Score 3

Comments:

Thanks for your reply,

Unfortunately, I followed your tips but it didn't work.

I think the problem is in one of the circuits. I took him to a maintenance worker and I'll see what he'll say.

by

Add a comment

hey

just take off the battery and push the power button for 5 seconds then put it back and let the charge for about 4 hours maybe he start again

good luck

Was this answer helpful?

Score 1

Comments:

Hi,

It doesn't work, the problem is in the circuits I think.

Thanks

by

Add a comment

1. try to do cycle power.

2. if this not working. try to discharged (unplug the batt connector from the motherboard)

. and plug it back after a few seconds .

it works for me long time ago.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Mohammed Ed will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 10

Past 30 Days: 46

All Time: 599