Riding mowers built for K-Mart by MTD and Murray.

17 Questions View all

deck belt won't engage blades

Took the deck off my 38" 12hp PowerPro so I could sharpen the blades. When I put deck back on, the belt won't engage the blades...too much slack. Is there an adjustment for this?

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

You are correct L Pfaff, this is a very simple belt routing and I had it right. My guess is that the belt is stretched; going to order a new one. Thanks for the answer!

by

@donovanb,Donovan, Thanks for replying back, wish you good luck with your mower.

by

Add a comment

1 Answer

Chosen Solution

Donovan B, I looked through the manual and does not show any adjustment for the deck belt and I assume you have belt routing correct(links below have routing) as looks pretty easy compared to some, maybe recheck your deck installation, springs/arms/etc.. I new belt, either you were given the incorrect belt size MTD 954-0329A V-BELT .625X69.28, or that the pulley's may be badly worn or old belt stretched.

I posted links below to show the belt routing, correct belt# and the various spring positions. The 2nd link is where you can down load your owners guide/manual. Good luck. I hope this helped you out, if so let me know by pressing the helpful button.

https://www.jackssmallengines.com/jacks-...

http://www.mtdparts.com/equipment/mtdpar...

Was this answer helpful?

Score 2
Add a comment

Add your answer

Donovan B will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 3

All Time: 38