New ink installed, will not print --?

Black ink was full, but would not print. Cleaned print heads, and only red printed boxes. Cleaned heads 4-5 times, still no ink on paper. Printer acts and sounds like it's printing, but nothing come out on paper. What to do?

Edit: "All 4 cartridges were replaced with Epson brand cartridges."

Answer this question I have this problem too

Is this a good question?

Score 5

Comments:

All 4 ink cartridges were replaced with new Epson ink.

by

I have the same problem. Spent the money for all 4 new cartridges and nothing gets copied or printed. The printer is only 2.5 years old & used sparingly in my home. I copy/ print maybe 80 pages PER YEAR. The Epson support rep. did the same cleanings I had done 6 times. & said I had a hardware failure. This is NOT acceptable to me. NO MORE EPSON products for me!!!!!!!!!!!!!!!!!!!!!!!!!

by

fyi. I was at Office Depot yesterday and they said to bring the new cartridges back for a full refund if printer still would not print after installing.

by

this happened to me today... I have and hp 3526 printer. I tried both brand new black ink cartridges... says they are full but will not print any black

by

Thank you so much. This worked for me. Wow.

by

Show 1 more comment

Add a comment

2 Answers

Most Helpful Answer

it worked for my HP :

take your inks out, turn off the printer (disconnect it from the power while the cardriges are out)

clean the gold pins with some cloth or Isopropyl alcohol or so

turn on the printer (it will say no ink)

than just put the ink back in and try to print

i fixed my HP 10x like this

Was this answer helpful?

Score 6

Comments:

It worked!! Thank you.

by

tried it and it did not work :(

by

Thank you for posting. It worked!!

by

Quick and easy fix! Thanks for posting!!

by

unfortunately, it didn't solve issue

by

Add a comment

press the ink cartridge s until they click into place

Was this answer helpful?

Score 0

Comments:

This is not a helpful answer. By the original question it is obvious that we all know how to properly install the ink cartridges and have even cleaned heads, replaced ink completely. It is much more helpful if responders read the complete question/string before answering and not just respond to increase your post count. Thank you.

by

Not Helpful hear other. I had this issue twice now. I wen and bought another EPSON. Not again.

by

Add a comment

Add your answer

healybg will be eternally grateful.
View Statistics:

Past 24 Hours: 55

Past 7 Days: 399

Past 30 Days: 2,219

All Time: 15,393