Model A1297 Unibody: Early 2009, Mid 2009, Mid 2010, Early 2011 & Late 2011

431 Questions View all

Backlight not working but fuse f9800 is OK.

Hi everyone,

About a month ago my Backlight failed, I began scouring this site and found a few threads about the f9800 fuse. I checked that and sure enough it was blown. I had a friend solder a replacement fuse and I put the MBP back together with a brand new LVDS cable and all was well.

About 24 hours later the Backlight went again. I stripped it and checked the f9800 and this time the fuse is perfectly fine. When putting it back together there was a brief second where the Backlight worked before going back to not working.

My question is, what do you suggest I look at next?

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

@vish8895 it will help us if you identify your computer exactly. Or even better, give us the 820-XXXX number on your logic board. That way we are all on the same page.

Rep: 1

by

Add a comment
Deck the Halls
With tools and Fix Kits

1 Answer

Chosen Solution

Possibly a bad LVDS cable? Try moving the cable and seeing if it cuts out. If backlight cuts out and cuts back in sometimes, it usually indicates this (since it means the backlight circuit is able to light the screen). If not this, it could be the screen, or maybe a strange issue with the logic board (I haven't seen one like this before though, where it was a logic board fault).

Was this answer helpful?

Score 2

Comments:

Hi,

Thanks for your response, as I mentioned in my question I replaced the LVDS cable with a brand new one as I suspected the same.

Currently wondering if the LVDS connection on the LCD panel is damaged as it did look slightly damaged when I removed the standard LVDS cable (the laptop had a replacement LCD last year).

by

Add a comment

Add your answer

vishal tween will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 2

Past 30 Days: 16

All Time: 88