Garmin Express can't find my device

I've used two computers with Garmin Express and neither one can't recognize the watch is connected. It is fully charged and it acts like no software is present.

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment

1 Answer

Most Helpful Answer

Hi,

The user manual says that

To prevent corrosion, thoroughly dry the contacts and the surrounding area before charging or connecting to a computer.

Have you tried cleaning the contacts on the watch where the USB cord plugs into?

Does the watch indicate that it is charging when you connect it to a USB port? If it is showing fully charged, disconnect it from the PC and use the watch for a while to run the battery down a little bit then connect it via USB again and see if it starts to charge.

If it doesn't show that it is charging or even if it does and it still wont connect after you have cleaned the contacts then it is either a faulty USB cord or a faulty USB controller in the watch. If you have access to another compatible USB cord for the watch try it and see if it works. This will prove whether the problem is in the cord or the watch.

Was this answer helpful?

Score 3

Comments:

If the connection works but still can't find a satellite were can I take it to get worked on in California?

by

hi @dkcollier ,

As you will have all the required information the best way may be to use this link. https://my.garmin.com/rma/en-US/repair/r...

by

Add a comment

Add your answer

Dan Collier will be eternally grateful.
View Statistics:

Past 24 Hours: 9

Past 7 Days: 38

Past 30 Days: 117

All Time: 2,099