Dymo LabelManager 160 is fast, compact and lightweight, making it easy to label just about anything, anywhere. Type quickly on the computer-style QWERTY keyboard, edit with one-touch fast-formatting keys and print for perfect, professional labels every time.

9 Questions View all

Ribbon doesn't move when printing

I push the 'print' button' and , although it make some sound, and one of the wheels is turning (the one on the middle bottom) the ribbon doesn't move.

How to fix it?

Answer this question I have this problem too

Is this a good question?

Score 2

Comments:

changed cartridge and still doer not put out tape !

by

Another possible problem to look for: when you close the door to the tape-holding compartment, look to see whether the writing head moves to pinch the ink ribbon and printed tape together. If it does not, the hinged wire and spring component with a hook at the end may no longer be attached to a plastic eyelet that normally allows this pinching action to occur. This can be challenging to fix, which is a shame, because a tiny plastic part brings down the whole operation. I have not managed yet to fix this on my own label maker.

by

Add a comment

1 Answer

Hi!

I would suggest that you try a different cartridge. Most likely the ribbon is broken inside the cartridge. You can test this by turning the spool in the direction of the arrow with the cartridge out of the machine. These cartridges are designed to be removed/swapped in mid cartridge, so you won't be messing anything up by pulling it out.

Cheers!

If you found that information to be useful, please Up Vote or Accept Answer

Was this answer helpful?

Score 0

Comments:

I've already tried with a new cartridge so I don't think this to be the problem :/

by

Hi!

Would you be able to post a pic of the compartment?

Cheers,

Joshua

by

I tried to view the image, but it says that I do not have permission to view it.

by

It just downloads when you click this URL.

by

Show 1 more comment

Add a comment

Add your answer

cesderty will be eternally grateful.
View Statistics:

Past 24 Hours: 10

Past 7 Days: 63

Past 30 Days: 205

All Time: 1,834