Messed up repair. Loud popping noise and power shuts off.

I was performing what should have been a simple C Stick replacement, but I goofed it up. I was following this teardown video but realized I could access the C Stick without removing the entire motherboard. I realized this after removing the first 3 ribbons as shown in the video.

After replacing it I rebuilt it and replaced the ribbons. In doing so, the second and smallest ribbon removed seemed to have its clip damaged.

Block Image

When I tried to power it in, the blue led came on, it sat for 4 seconds, and it made a loud popping noise.

Searching this site, I managed to discover that meant either a fuse was blown or a ribbon was out of place. I have since attached and reattached the ribbons hoping but have had no luck in resolving the issue.

The broken clamp does not seem to have anything on the clamp itself that would have any purpose other than holding it in but I'm afraid it could have some connection I have damaged.

What are my steps from here? Do I check the fuses or try taping down the suspected ribbon or do you see something in either of my picture I've missed? Honestly I've just been messing with this for 2 hours and need a new pair of eyes that know more about this than me.

Thank you!

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

@spideyab you are absolutely right when you say that the clamp serves the "purpose other than holding it in". By doing this it put pressure on the ribbon cable and thus the cable makes contact. Without the clamp it dies not or only brielfy, this can lead to the symtoms you are having. Without a proper clamp you are going to run into issue. See if you can either find a replacement or buy a board where you can harvest the connector from.

Was this answer helpful?

Score 2

Comments:

@oldturkey03 You were right it is just a pressure thing. When I push down on it with a flat head, it remains powered. Can you think of a way I could a similar pressure to the outside? Maybe electrical taping something on top of it.

by

You could try electric tape but it will not hold for very long. There is a cloth tape that was used in "older days" that had more adhesive property. I believe 3M still makes products like that.Not sure where you are so you may have to check around your neighborhood. Ultimately only a repalcement of the connector will fix it properly

by

Add a comment

Add your answer

Alex Bennett will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 69