Second generation of iPhone. Model A1241 / 8 or 16 GB capacity / black or white plastic back. Repair is more straightforward than the first iPhone. requires screwdrivers, prying, and suction tools.

1500 Questions View all

iPhone 3G not powering up after housing change, why?

Hi! Changed the housing on an iPhone 3G, now it just won't power up. The power button/flex is not the culprit here, because if it's on the charger I can get the Apple logo for about 5 seconds; then the screen goes blank like an old Game Boy (fades out as if power abruptly cut)

It will not enter recovery or DFU mode because I can see the screen flashing black every 1-2 seconds when plugged into a computer.

Tried replacing the battery, no go. Reseated the board, no go. Cleaned it with 99% IPA, let it dry, gave it a go with the heat gun, no go. I put another logic board in there to test fitment, grounding, etc. it works!

Ordered a dock flex assembly, going to see if it helps. Anyone have any ideas? It's running 3.1.3 (Sn0wbreeze pwned) if that helps.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment




Spread the Fixmas cheer.


Spread the Fixmas cheer.

1 Answer

Chosen Solution

Check your battery contacts on motherboard are clean and undamaged too. Could be dock connector/ cable 4 . Does alternate motherboard power up and work in new housing?

Was this answer helpful?

Score 1


Try swapping non working motherboard to other case and see if it works in known good case. Then you'll be able to tell if board is at fault or coonnections


Checked all the connections, tried with a good board, it does indeed work.

Gave it a good scrub with IPA once more, this time using a sonic toothbrush, and a good go with the heat gun. Got DFU mode! 3.1.3 is restoring right now :)




Tried a couple of things to get it to work, can't get sn0wbreeze or regular 3.1.2 or 3.1.3 to restore.

Keeps throwing error 1601 whenever I restore anything (doesn't ever actually restore, 1601 after the "Preparing iPhone for restore"), still only powers up for 5 seconds on AC power, no power at all if battery only, and does the black screen thing when connected to a computer. The only difference now is I can get it into DFU mode :(


have you tried a different usb cable?checked usb cable for damage and dirt? is your itunes up to date? sorry but apple doesn't see fit to include what error 1601 is... try with dodgy board in working shell


Show 5 more comments

Add a comment

Add your answer

sheik124 will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 3,795