totally lifeless, please help

Hi

my tablet tab2 10.1 is totally dead, i plug one of my chargers in and nothing happens i tried holding the various key combinations in and still nothing, i tried unplugging battery lead inside tablet still no joy. had multi-meter on battery reading 3.321v slightly under rating on battery, i wouldn't have thought it would be enough to stop it working. what should i do next? i am competent with a multi meter and soldering etc

any help is highly appreciated

regards

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment

1 Answer

Check if the power button/switch is working with the continuity tester on your multimeter. Often the cause of these sudden no power problems is a bad button.

Was this answer helpful?

Score 0

Comments:

hi thanks for the reply, but when i connect charger there is no battery symbol appearing on screen like it used to, i would have thought if it was button it would display when charger inserted like it usedto

by

Try booting up without the battery and see if you get any signs of life. If that fails, try removing individual components and booting up,isolating the problem to the logic board and charge port/dock connector. Also, you may want to try replacing the charge port/dock connector if it is easily replaceable.

by

Add a comment

Add your answer

Richard White will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 49