Won't power up after hard drive swap

Hi,

I cloned/swapped my old hard drive to a 1TB HD, booted from the new drive through a SATA>USB adapter, shut down, and installed the new hard drive.

That's when things got weird. It wouldn't boot from the new drive, leaving me with the flashing "?" folder image a few moments after the boot noise. No boot in recovery mode, no option boot.

So I cracked it back open to check my connections. Unplugged keyboard, then I realized the power adapter was still in. My heart sank. Since that moment, I haven't been able to boot from any drive, or even get the machine to power on.

Keyboard ribbon connector is snug, and the ribbon seems undamaged after close scrutiny. I tried a pram and smc reset, but the keyboard doesn't even seem to be getting power.

I don't want to spend much more money on an 8 year old machine, but I don't want to scrap it unless I know for sure it's toast. Is there a way to boot this sucker?

Update (05/11/2016)

UPDATE: Anyone else who made this mistake and can't make their machine take power, disconnect your pram battery and reconnect it. The machine should now take power and boot again.

Be sure not to pop the pram battery connector off the motherboard entirely- it's a relatively common mistake, and non-fatal- but it makes your computer take much longer to boot from a dead battery.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Can you give us the make & model of the HD you put in.

In these older MacBook Pro's you do need to use the correct drive as the SATA port is only SATA I (1.5 Gb/s). The fact the drive worked externally tells me you likely got the wrong drive for your system or will need to set a jumper if it offers it.

Let's start there before we go wild swapping out the SATA cable or doing anything else here.

by

I got a WD Blue 1TB 5400rpm (http://www.newegg.com/Product/Product.as...)

After disconnecting the pram battery, I got the machine to boot again (boots from old drive on SATA, as well as on new drive from SATA/USB adapter, but not with the new drive on SATA). Next, I'm reformatting and re-cloning the new drive to see if that solves anything.

by

Mike - See below for the full story. You need a different drive here.

by

Add a comment

3 Answers

Chosen Solution

Your WD Blue drive is a fixed SATA III (6.0 Gb/s) drive. Your system only has a SATA I (1.5 Gb/s) HD interface.

Sadly, this combo won't work. The problem is the SATA standard was not forwards compatible from the drives perspective, it was downwardly compatible!

So, simply put, if you got a new system which had a SATA III interface the older SATA I drive would work in it! Here we are putting in a drive the system has no idea how to work with as the drive technology is newer than what it knows (putting a SATA III drive in a SATA I system).

Now let's talk about the exceptions! As it turns out a few drive makers realized people wanted to put bigger sized drives in their older systems so they created a new class of drive which had the ability to match up with the systems SATA port. Basically, it has a means to sense the systems SATA port and match it. Not all drives have this ability! In this case this drive does not!

Here's a reference of a drive that does: Seagate Laptop SSHD. If we jump over to the spec sheet: http://www.seagate.com/www-content/datas... and we look at the line Interface we can see all three data rates of SATA I, II & III are listed. This drive has auto I/O sense technology! This would be the best drive for you system.

Was this answer helpful?

Score 1

Comments:

You'll need to return the WD drive and get one that has auto sense or is a FIX'ed SATA I (1.5 Gb/s) drive. HINT: Go with the Seagate drive! You get better performance than the WD drive. Review the difference between a traditional HD and a hybrid HD drive. The hybrid drives (SSHD) are much better!

by

Dan, you are the man.

by

Add a comment
Most Helpful Answer

There a good chance you damaged the drive cable. This flex is definitely a very fragile cable and manipulating it often cuts some wires.

Buying a used flex cable is not an option for the same reason.

First, try using your drive as an external drive of a functional Macbook, hold Option key while booting, then select the external drive.

If it starts, the disk is fine, just power off before the boot process completes (hold power button until it switches off).

A working disk means your flex cable is dead. Buy a new one and replace it (please be very careful when manipulating it).

Was this answer helpful?

Score 2

Comments:

I think my flex cable might be inadequate for the new HD (http://www.newegg.com/Product/Product.as...).

After disconnecting the pram battery, the computer was able to take power and boot from the old drive on SATA, as well as booting the new drive from a USB/SATA adapter. So this isolates the SATA connection. My preliminary research told me that a SATA III drive would work fine on SATA I, but would simply be limited to SATA I transmission speeds.

I'm reformatting and re-cloning to see if it makes a difference. After this, I'll purchase a new SATA cable. If that doesn't work, I suppose I'll wipe it and slap it in a USB enclosure :/

by

Add a comment

The strange thing about MacBooks is they do NOTHING unless there is bootable media so... If you fried both of your drives then well it won't do anything all you will get is a white screen...

Also if you were messing with the insides with either the battery or power still connected there is a good chance you fried the hole computer...

Was this answer helpful?

Score 0

Comments:

Nah, I disconnected the pram battery (accidentally ripped it off the motherboard... it's not a quick connector like the keyboard...... $@$*) and it boots from the old drive, and it still boots from the new drive on USB.

by

Add a comment

Add your answer

Michael will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 98