Can browse, but cannot download via wifi

Hi There, Could anyone help me?

I have my Alcatel One Touch Pop C7. With the provider's nw it works fine, can download, runs fast.

Via my home secure wifi connection, in most cases i cannot download (no matter from where, Google Play, or streaming webradio). When downloading via Google play, it downloads literally kilobytes by kilobytes, or while streaming, constantly buffering, with 'no results'. It works only fine sometimes, i haven't found the reason.

Could be the router, but we have two more phones (samsung and huawei), and they work fine. No G.Play or streaming problems. We are using the same wifi nw connection of course, same user, tried to update same apps on the phones, but only the Alcatel has this issue. What can be wrong with it? Could you tell me? Maybe any other infos required, please ask, i'll reply asap. Thank You

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Hi,

I'm assuming when you say your provider's nw you mean the mobile phone's cellular data connection, is this correct? This is a different connection to a WiFi connection.

Have you tried using it with no other phone connected via WiFi to the router to see how it performs? Does it perform normally when using it close to the router?

This link may be of some help.

https://www.androidpit.com/improve-wi-fi...

Was this answer helpful?

Score 3
Add a comment

Add your answer

mcsm75 will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 1

All Time: 113