Samsung GT-I8160 USB MTP drivers not installed?!?

Hi there

For some reason from the day after i cannot access my phone from my PC. On windows 7 device manager i got the yellow sign (!) "device USB MPT".

I installed Kies Samsung and usb mtp drivers windows 7, still nothing. Anyone can help?

I think that the problem might be on my device's micro usb port fault. What do you think ?

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

Free shipping on all orders over $100 or containing a Pro Tech Toolkit!

Browse Our Store

1 Answer

Chosen Solution

Problem solved !

There are 4 main pins you use on micro USB. 5v, GND, D+ and D-. My data lines are damaged coz i tried another cable and both cables on another PC with same results.

Well, i wll change the micro usb port.

Was this answer helpful?

Score 0
Add a comment

Add your answer

mgaltanas will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 4

All Time: 582