The Toshiba Satellite Click 2 Pro is a 13 inch simple and easy to use hybrid laptop, created by Toshiba in 2014

14 Questions View all

Device won't take a charge

I know this is a very long question, but I attempted to be completely thorough about my troubleshooting steps taken and description of symptoms shown by the device so that it can help point whoever helps me fix this thing in the right direction (and with that becomes my new best friend too.)

Okay, So I need help running through this Toshiba Satellite Click (model W35Dt-A3300)

It was brought to me running on AC Adapter, but as soon as it's unplugged, it dies, the other technician replaced the battery in the base, however, this didn't fix the issue, and so it was pawned off on me the "master" technician (really just master researcher).

Okay, so this is what I did, I started with the assumption that the other technician completely flubbed the repair, as even with a new battery in the base, the device shows a red X next to the battery.

I took the tablet side apart and took the battery from the base (assuming this battery is good as it was just purchased - I'm not exactly sure how to test a battery using a multimeter) I swapped the battery in the tablet side with the battery in the base side (the base side was new, and the tablet side is known bad, however the old base side is unknown whether to be good or bad) and plugged the charger directly into the tablet side.

No power on whatsoever, however, a very faint electrical hum can be heard coming from the mainboard underneath what appears to be the tablet CPU/GPU heatsink.

I use Multimeter to test Continuity throughout the DC Jack (at the plug, and then again at the solder joints the plug connects to) and all tested for continuity.

I plug the charger into the base side, with the bad battery in it, and the device now boots up. the red X is now gone, however, the moment the device is unplugged, the tablet side shuts down once again, and the battery gauge doesn't fill even after several hours of charging.

Obviously the fault lies within the current going from the board to the battery in the tablet side, and obviously the current which I believe IS reaching the mainboard from the DC Jack, is obviously experiencing some sort of ground fault.

My true question falls into the category of this: has anyone else dealt with this type of device and issue? What was your outcome?

Secondary and more important question I believe (teach a man to fish ya know?) How do I go about testing the electrical system to FIND this ground fault location? What settings on my multimeter need to be used to accurately test the individual legs of current flow in the device so I can find what exactly the problem is without just feeling like I totally failed this customer and have to say "I dunno, bad motherboard?" (I hate faulting the Mainboard and having to replace the entire thing.)

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

Alright so I went to the drawing board and downloaded board diagram to check the current flow in the device because I heard a hum with the device plugged into the screen, and then a ten year old lesson from Electrical Technology hit me - humming is frequently transistor undercurrent - not what I was thinking as a ground fault. The device had intermittent power failure under random circumstances - all of which I deduced was from the CPU or HDD drawing any sort of actual current rather than standby levels.

The end result was going back to drawing board and assuming my colleague was a total doofus and did a half-hearted Dx.

I went back to point A and tested the AC, then tested DC volts which were spot on at 19.1V, and then I decided to check out the current levels and the DC current was jumping all over between 0.01-1.19A

The dang charger was bad, and the colleague ordered batteries and sent it uphill for major board level testing without doing the basics.

Never forget to literally listen to you PCBs in the event of power issues - whining is too much Amps and humming is too few, transistors like the proper numbers

Was this answer helpful?

Score 0
Add a comment

Dear, i am facing same issu. Please tell me how to fix??

If i connect the charger i turns on, even 3 , 4 hours of charge if i remove the charger cable it directly turns off.

How to fix?

Was this answer helpful?

Score 0
Add a comment

Add your answer

dailianmoon87 will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 22

Past 30 Days: 120

All Time: 1,353