Announced in March 2015, and released April 10, 2015, the Galaxy S6 is the next flagship in the Galaxy line. The curved screen version is known as the Galaxy S6 Edge.

273 Questions View all

s6 motherboard boot loop/freezing after water damage repair, hardware

Hello, phone had minor water damage, not fully submerged, and customer brought it in with no power.

After cleaning w/ 99% isopropyl alcohol and a run through the ulrasonic cleaner, it will power on and boot to samsung logo, download mode, or recovery mode.

Tried flashing stock rom (older versions and then newest firmware) and no change.

At one point I was able to get it to boot normally but it rebooted after a minute or so. Most times it freezes on the samsung logo, sometimes it reboots on the samsung logo.

Tried many different combinations of factory data reset, clear cache partion before and after flashing stock rom.

So it is a hardware issue. Motherboard does not have any hot spots nor corrosion visible under 10x.

Any help or advice troubleshooting this on s6 or s6 edge appreciated. A google search turns up nothing substantial, although some others have similar (unanswered) questions

I am comfortable micro soldering, replacing components and wanting advice on how to troubleshoot this repair

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

No luck with either the soak or reflashing as described above.

Anywhere to check specifically on the motherboard for damage?

by

Add a comment

2 Answers

I have had this same exact thing happen to me and I spent so much time trying to fix it. Way later after I had that repair, someone finally gave me the advise to soak the motherboard in the alcohol over night. I wish I still had that phone so I could try it.

Was this answer helpful?

Score 0
Add a comment

Try flashing again using odin. I've had this issue also myself (several times) and somehow on 2 of 4 of the cases, some combination of flashing the firmware 4 or 5 times cleared it up.

download the stock firmware file again, preferably from a different source. check the md5.

this may be obvious, make sure you are flashing the same version or newer, you can not flash older. make sure you are flashing the correct firmware for the model. I have for example seen some motherboards with sm-g920v written on the board, but installed with sm-g920p software. In this case, flashing sm-g92Ov firmware would fail. I believe it was a factory refurbished phone/motherboard.

You can also try flashing the firmware file without the cache.img

extract and compile (using free software / scripts that you can download online) the firmware .md5 file with only the boot.img and system.img, NOT the cache.img then flash under the ap tab on odin.

I am also quite curious about a hardware solution, I believe this is a fairly common issue! Good luck!

Was this answer helpful?

Score 0
Add a comment

Add your answer

albert einsteen will be eternally grateful.
View Statistics:

Past 24 Hours: 2

Past 7 Days: 15

Past 30 Days: 50

All Time: 1,487