The first model of iPhone, Model A1203 with 4, 8, or 16 GB capacity and an aluminum back. Repair requires a significant amount of prying, and may require some soldering.

277 Questions View all

No signal after replacing battery, battery drain with SIM

I have an 8gb A1203 and just replaced the battery. I get the "no signal" message after booting up. It will stay like that forever. If I turn airplane mode on then back off, it changes to "searching...." and stays like that till the battery drains and the iPhone shuts itself off. With a fully charged battery, this happens in less than 15 minutes. I have verified that the SIM is good in another phone. The battery seems to discharge normally when in airplane mode or the SIM is out of the phone. I have tried resetting the network settings several times and verified that the antenna connections are seated properly. I don't know what else to try. Please tell me I have not converted my iPhone into an iPod touch!!!!

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

it sounds like an antenna problem. if the phone can't get a signal it uses loads of power searching. i'd go back and check again.

Was this answer helpful?

Score 1

Comments:

I have rechecked the antenna connections with a magnifying glass twice. Everything looks good. I tested the continuity of each of the cables and they are good too. I re-flashed the phone and re-unlocked and jail-broke and I am getting the same symptoms.

by

i'd try reseating all the antenna connections again. i know its tedious but sometimes its not obviously out of line. otherwise it could be the wires themselves that are damaged.after that? i'm not sure. sorry i couldn't be of more help.

by

I took it apart and reseated the antenna connections. I get the same problem. Wifi and BT work just fine. Do they use a common antenna or does each system rely on a different antenna? I am at my wits end here. Any other suggestions are appreciated. Thanks

by

Add a comment

I had the same problem after doing a battery replacement on my 2g. I tried tightening the middle screw down at the bottom of the metal housing where it attaches to the chassis a little more. This screw holds one of the antenna connector wires in place and I think that is what did it.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Matthew will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 1,871