The fourth iteration of the popular 7" Galaxy Tab line of Samsung tablets.

124 Questions View all

Apps shut down, screen gets dark then won't answer to taps

I've had a Samsung Galaxy Tab 4 (SM-T230NU) for about a year or two, and I just had an issue with it today.

I can't seem to be able to do just about anything- First I couldn't log into a social media app, then I could no longer watch any video, may it be from Youtube or Facebook, or any places, really.

I then could no longer log into any app (Facebook, for instance) and brightness of my screen went down and I can't seem to be able to tap/open anything, and I can't get the menu to turn off/restart open, but I can lock it. I can also press the home screen afterwards, put the password to access my Tablet, but the screen would still be dark and wouldn't respond to taps.

I can let it down for about five to ten minutes then open it again (put the pw, tap around) but the reaction would depend on the app (for instance, if it's Facebook, I can open it, but the screen would turn black before showing the page I was recently on, then if I touch something else from the app, it'll flicker then close and the screen's brightness will go down again.)

I tried leaving it for 5 minutes to be able to get back in and turn it off, but the menu to restart/turn it off doesn't appear and the screen freezes for a brief second, but doesn't get dark and still is possible to play around with, but the same problems occur from what I said recently (Press a video or app, it'll close the app and the screen darkens plus doesn't respond to taps.)

Anything I could do?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Hi,

Does the tablet indicate that it is charging when you connect it to the charger?

If not try another charger and see if it will charge. If still not you either have a faulty charging circuit in the tablet or a faulty battery.

If it does charge, allow it to fully charge and then try it. If it still fails to function properly when running on just the battery, try running it with the charger connected and switched ON. If it works normally now it indicates that you have a faulty battery.

To replace the battery, I suggest that you take it to a mobile phone / tablet repair centre

Was this answer helpful?

Score 2
Add a comment

Add your answer

Miausz will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 116