A touchscreen smartphone made by LG released in September 2013 with the model number VS980.

224 Questions View all

LG G2 doesn't get past logo

Trying to repair an LG G2 for my friend.

Replaced it with refurbed LCD initially, and I got the charging at 0% icon. Pulled it out and went to sleep.

Next day when I tried to charge it, it boots up, shows the LG logo, then screen goes blank. LG logo appears again and repeat infinitely.

I've tried using a different battery, different bottom connector/usb, different LCD and it's still the same. The only thing left is the motherboard itself, but I don't have spares to test. I really doubt it could be the motherboard as it could show charging at 0% the day before.

It seems like either the motherboard won't let it charge properly, or it doesn't seem to be able to charge? Anyone has any experience with this? Would it require a forced charge or a jump start?

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment

1 Answer

Since it actually shows the logo, it has the energy to start.

It sounds like you have a software problem. What you are describing is called a boot loop.

Was the OS was corrupted? Maybe virus or bad attempt at custom Rom?

Ask your friend about what she/he did software wise.

Was this answer helpful?

Score 0
Add a comment

Add your answer

weyxiang will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 6

All Time: 131